Bug 1124808 - [webadmin] bond gets visually broken if its slave is ifdowned
Summary: [webadmin] bond gets visually broken if its slave is ifdowned
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Lior Vernia
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 11:33 UTC by Martin Pavlik
Modified: 2015-05-05 01:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 12:18:59 UTC
oVirt Team: ---


Attachments (Terms of Use)
log_collector (14.53 MB, application/x-xz)
2014-07-30 11:33 UTC, Martin Pavlik
no flags Details
screnshot: before ifdown (108.27 KB, image/png)
2014-07-30 11:33 UTC, Martin Pavlik
no flags Details
screnshot: after ifdown (107.08 KB, image/png)
2014-07-30 11:34 UTC, Martin Pavlik
no flags Details
vdsClient outputs before and after ifdown (42.82 KB, text/plain)
2014-07-30 11:35 UTC, Martin Pavlik
no flags Details

Description Martin Pavlik 2014-07-30 11:33:16 UTC
Created attachment 922502 [details]
log_collector

Description of problem:
if one of host bond slave interfaces is manually shutdown using ifdown command and refresh host capabilities button is used afterwards, the slave which was shut down is removed from bond in Host -> Network interfaces sub-tab 

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.5.0-0.0.master.20140722232056.git8e1babc.fc19 

How reproducible:
100%

Steps to Reproduce:
1.create bonded interface at host (via Setup Networks)
2.ssh to host and use ifdown command to shut down one of the bond slave interfaces (e.g. ifdown p1p1)
3.hit "Refresh Capabilities" button in webadmin

Actual results:
slave interface which went down is removed from the bond 

Expected results:
slave interface remains in bond and is marked as down

Additional info:
- interface is returned to the bond after ifup is used on it
- vdsClient before and after ifdown are attached

Comment 1 Martin Pavlik 2014-07-30 11:33:58 UTC
Created attachment 922503 [details]
screnshot: before ifdown

Comment 2 Martin Pavlik 2014-07-30 11:34:29 UTC
Created attachment 922504 [details]
screnshot: after ifdown

Comment 3 Martin Pavlik 2014-07-30 11:35:31 UTC
Created attachment 922505 [details]
vdsClient outputs before and after ifdown

Comment 4 Martin Pavlik 2014-07-31 09:06:17 UTC
if both interfaces are ifdowned, bond in GUI (netowrk subtab and setup networks dialog) just disappears completely

that is very confusing for user (it appears like bond is not configured at all)

Comment 5 Lior Vernia 2014-07-31 09:33:05 UTC
I think that it appears like the bond is not configured at all because it isn't configured at all. If you ifdown both interfaces, then they're disconnected from the bond, and oVirt doesn't display bonds that aren't connected to any interface. If you want to simulate a case where there's some malfunction, use "ip link set <DEV_NAME> down".

Dan, correct me if I'm wrong.

Comment 6 Dan Kenigsberg 2014-07-31 11:28:51 UTC
Well, an interface can be down, but still connected to a bond device. However, the ifdown script explicitly takes it out of the bond.

I think that it would be cool if Engine could handle a bond with no slaves (it should be considered non-functional, of course).

In any case, this bug is not urgent: if someone logs into his hypervisor and messes his network, we show that the network is messed up. Any complimentary information is welcome, but not urgently needed.


Note You need to log in before you can comment on or make changes to this bug.