Bug 1124818 - RFE: Allow selecting multiple snapshots for sequential deletion
Summary: RFE: Allow selecting multiple snapshots for sequential deletion
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 11:56 UTC by Martin Kolman
Modified: 2014-09-20 23:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-20 23:40:17 UTC


Attachments (Terms of Use)

Description Martin Kolman 2014-07-30 11:56:46 UTC
Description of problem:
Currently it is only possible to delete one VM snapshot at a time. Depending on snapshot state the delete operation can take a non-trivial amount of time, which can add up quite a bit if you want to delete multiple snapshots (for example before reinstalling a Rawhide VM) as you have to delete one, confirm deletion, wait for the operation to finish - over and over again up to the last snapshot.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. make 2 or more snapshots for a VM
2. try to delete the snapshots

Actual results:
You can only delete the snapshots one by one.

Expected results:
You can select multiple VM snapshots (say using shift or "rubber band" selection) and delete them at once.

Comment 1 Cole Robinson 2014-07-30 14:21:48 UTC
This is not possible at the qemu level, snapshot operations are currently synchronous and block all qemu monitor usage while they are being invoked.

That could possibly be 'fixed' by making the commands async, which there are vague plans to do, however two snapshot delete operations still likely wouldn't be able to take place automatically, since the data for all snapshots is stored in one file (the guest's qcow2 disk image). So really this fundamentally isn't possible given the way internal snapshots are architected. Closing this CANTFIX

However given all that, there's probably things we can do in virt-manager to make this more clear, since there's issues like your other bug reports

Comment 2 Martin Kolman 2014-07-30 14:31:47 UTC
Well, I think I should have been more clear in my RFE - I didn't mean asynchronous snapshot removal (which would be indeed nice, but as I agree it is not doable at the moment) but "batch snapshot removal":
1) select a bunch of snapshots
2) click delete
3) confirm the deletion
4) Virt Manager deletes the snapshots sequentially

The main improvement being that the user does not need to manually delete & confirm deletion of every snapshots he wants to delete (not to mention the time spent checking if the current removal has finished so that the next one can be started) - thus saving the time of the user even though the deletion process itself running in the background still takes the same time.

Comment 3 Cole Robinson 2014-07-30 14:37:50 UTC
Oh, sorry for the misunderstanding. That sounds feasible, at least worthy of investigating. Reopening, moving to the upstream tracker

Comment 4 Giuseppe Scrivano 2014-08-01 07:43:49 UTC
fixed upstream by:

commit f5b29c0416be5d05f2d684070d84c7600601907c
Author: Giuseppe Scrivano <gscrivan@redhat.com>
Date:   Thu Jul 31 14:28:54 2014 +0200

    snapshots: allow deleting multiple snapshots
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1124818
    
    Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.