Bug 1124827 - RFE: Enable ECDHE support in sendmail
Summary: RFE: Enable ECDHE support in sendmail
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sendmail   
(Show other bugs)
Version: 7.0
Hardware: Unspecified Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Roman Žilka
Lenka Kimlickova
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks: 1057566 1191019 1298243 1289025 1305230 1393869
TreeView+ depends on / blocked
 
Reported: 2014-07-30 12:15 UTC by Morten Stevens
Modified: 2017-09-14 13:53 UTC (History)
12 users (show)

Fixed In Version: sendmail-8.14.7-5.el7
Doc Type: Release Note
Doc Text:
*Sendmail* now supports ECDHE This update adds the Elliptic Curve Diffie-Hellman Ephemeral Keys (ECDHE) support to Red Hat Enterprise Linux 7 *Sendmail*. ECDHE is a variant of the Diffie-Hellman protocol that uses elliptic curve cryptography. It is an anonymous key agreement protocol that allows two parties to establish a shared secret over an insecure channel.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:42:36 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backported feature (858 bytes, patch)
2016-09-27 15:27 UTC, Jaroslav Škarvada
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2197 normal SHIPPED_LIVE sendmail bug fix and enhancement update 2017-08-01 16:09:20 UTC

Description Morten Stevens 2014-07-30 12:15:06 UTC
Description of problem:

Please enable ECDHE support for RHEL 7 as we have it for Fedora.
See: http://pkgs.fedoraproject.org/cgit/sendmail.git/commit/?id=509e9c8c3986e14a5fa698264f6b15a4ba2adb5f

Version-Release number of selected component (if applicable):

sendmail-8.14.7-4.el7.x86_64

Comment 2 Jaroslav Škarvada 2014-07-30 12:30:12 UTC
I am not sure whether this will get in, please escalate it through the support channel to give it prio.

Comment 5 James Ralston 2016-09-21 17:28:29 UTC
We want this as well. I'll escalate through our support channels.

Comment 8 Jaroslav Škarvada 2016-09-27 15:27 UTC
Created attachment 1205272 [details]
Backported feature

Unfortunately sendmail version in RHEL-7.3 is too old, thus the patch from the comment 0 is not enough and we need to backport the support. Full patch is attached.

Comment 10 Jaroslav Škarvada 2016-09-27 15:31:54 UTC
Scratch build for testing (unsupported):
http://people.redhat.com/jskarvad/rhbz1124827/

Comment 11 Jaroslav Škarvada 2016-09-27 15:32:52 UTC
(In reply to Jaroslav Škarvada from comment #8)
> Created attachment 1205272 [details]
> Backported feature
> 
> Unfortunately sendmail version in RHEL-7.3 is too old, thus the patch from
> the comment 0 is not enough and we need to backport the support. Full patch
> is attached.

It needs to be applied together with the patch from the comment 0.

Comment 18 Roman Žilka 2017-04-21 07:23:58 UTC
QA: Verified on all archs.

********** sendmail-8.14.7-4.el7 (faulty):

# for i in $(openssl ciphers|sed 's/:/\n/g'); do echo QUIT | openssl s_client -cipher "$i" -starttls smtp -connect localhost:25 2>&1 | grep 'Cipher\s*: [^0]'; done
    Cipher    : ECDH-ECDSA-AES256-GCM-SHA384
    Cipher    : ECDH-ECDSA-AES256-SHA384
    Cipher    : ECDH-ECDSA-AES256-SHA
    Cipher    : ECDH-ECDSA-AES128-GCM-SHA256
    Cipher    : ECDH-ECDSA-AES128-SHA256
    Cipher    : ECDH-ECDSA-AES128-SHA
    Cipher    : ECDH-ECDSA-DES-CBC3-SHA
    Cipher    : ECDH-ECDSA-RC4-SHA

********** sendmail-8.14.7-5.el7 (fixed):

# for i in $(openssl ciphers|sed 's/:/\n/g'); do echo QUIT | openssl s_client -cipher "$i" -starttls smtp -connect localhost:25 2>&1 | grep 'Cipher\s*: [^0]'; done
    Cipher    : ECDHE-ECDSA-AES256-GCM-SHA384
    Cipher    : ECDHE-ECDSA-AES256-SHA384
    Cipher    : ECDHE-ECDSA-AES256-SHA
    Cipher    : ECDH-ECDSA-AES256-GCM-SHA384
    Cipher    : ECDH-ECDSA-AES256-SHA384
    Cipher    : ECDH-ECDSA-AES256-SHA
    Cipher    : ECDHE-ECDSA-AES128-GCM-SHA256
    Cipher    : ECDHE-ECDSA-AES128-SHA256
    Cipher    : ECDHE-ECDSA-AES128-SHA
    Cipher    : ECDH-ECDSA-AES128-GCM-SHA256
    Cipher    : ECDH-ECDSA-AES128-SHA256
    Cipher    : ECDH-ECDSA-AES128-SHA
    Cipher    : ECDHE-ECDSA-DES-CBC3-SHA
    Cipher    : ECDH-ECDSA-DES-CBC3-SHA
    Cipher    : ECDHE-ECDSA-RC4-SHA
    Cipher    : ECDH-ECDSA-RC4-SHA

Comment 26 errata-xmlrpc 2017-08-01 12:42:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2197


Note You need to log in before you can comment on or make changes to this bug.