Bug 1124838 - [Doc] upgrade: we show service start instead of restart on 'Procedure 4. Upgrading a compute node'
Summary: [Doc] upgrade: we show service start instead of restart on 'Procedure 4. Upgr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Upgrade
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 5.0 (RHEL 6)
Assignee: Summer Long
QA Contact: Martin Lopes
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 12:31 UTC by Dafna Ron
Modified: 2014-09-04 13:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 13:06:36 UTC


Attachments (Terms of Use)

Description Dafna Ron 2014-07-30 12:31:56 UTC
Description of problem:

on upgrade service by service guide with live compute:
http://docbuilder.usersys.redhat.com/22776/#Upgrade_Compute_Nodes

on Procedure 4. Upgrading a compute node step 4: 

 Restart nova services:

# openstack-service start nova

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. follow procedure for upgrade in step by step with live compute
2.
3.

Actual results:

step 4 states we need to restart service

Expected results:

command show start service and not restart

Additional info:

Comment 1 Andrew Dahms 2014-07-30 21:50:58 UTC
Assigning to Summer Long, as the designated author for Nova.

Comment 2 Summer Long 2014-08-01 06:02:28 UTC
Dafna, it looks like only one service is being stopped in step 2, nova-compute, so all services are being restarted in step 4? I've updated the command, and added the actual stop command in step 2. Can you confirm this is the correct one?

topic, 36191, rev.689750
thanks, Summer

Comment 3 Dafna Ron 2014-08-01 12:11:15 UTC
restarting all services will reload any changes made if needed so I would say restart of nova services is the correct action.

Comment 5 Martin Lopes 2014-08-14 01:24:04 UTC
Looks good. Verified.


Note You need to log in before you can comment on or make changes to this bug.