Bug 1124858 - building on EPEL-5 fails with unittest/dht_layout_mock.c
Summary: building on EPEL-5 fails with unittest/dht_layout_mock.c
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 13:18 UTC by Niels de Vos
Modified: 2015-05-14 17:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
build.log from http://copr-be.cloud.fedoraproject.org/results/devos/glusterfs/epel-5-i386/glusterfs-3.7dev-0.34.git67a6f40.autobuild/build.log (83.03 KB, text/plain)
2014-07-30 13:18 UTC, Niels de Vos
no flags Details

Description Niels de Vos 2014-07-30 13:18:01 UTC
Created attachment 922581 [details]
build.log from http://copr-be.cloud.fedoraproject.org/results/devos/glusterfs/epel-5-i386/glusterfs-3.7dev-0.34.git67a6f40.autobuild/build.log

Description of problem:
EPEL-5 (both x86_64 and i386) fail with the following error:

  CC     dht_layout_unittest-dht_layout_mock.o
unittest/dht_layout_mock.c:77:2: error: no newline at end of file
make[5]: *** [dht_layout_unittest-dht_layout_mock.o] Error 1
make[5]: *** Waiting for unfinished jobs....
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Version-Release number of selected component (if applicable):
current master branch

How reproducible:
100%

Steps to Reproduce:
1. start a build on EPEL-5 (RHEL-5, CentOS-5 and the like)

Actual results:
Failure while compiling a test case.

Expected results:
Compiling should succeed.

Additional info:

Comment 1 Anand Avati 2014-07-30 13:25:11 UTC
REVIEW: http://review.gluster.org/8392 (build: fix compile issue in unittest on EPEL-5) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2014-07-30 15:28:11 UTC
COMMIT: http://review.gluster.org/8392 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 60f2e231bbf4daef11793710bb69bdfbcfca89a1
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Jul 30 15:19:38 2014 +0200

    build: fix compile issue in unittest on EPEL-5
    
    When building the current master branch on EPEL-5, the following error
    is observed:
    
          CC     dht_layout_unittest-dht_layout_mock.o
        unittest/dht_layout_mock.c:77:2: error: no newline at end of file
        make[5]: *** [dht_layout_unittest-dht_layout_mock.o] Error 1
        make[5]: *** Waiting for unfinished jobs....
    
    EPEL-5 has this gcc:
    
        $ gcc --version
        gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-54)
    
    The fix is simple enough, dht_layout_unittest-dht_layout_mock.c should
    have a line ending.
    
    BUG: 1124858
    Change-Id: I8ca7a1699fd1c35694073b9577f94ae525854713
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/8392
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Luis Pabon <lpabon@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.