Bug 1124869 - [RFE] Automatic notification of dead manifest situation
Summary: [RFE] Automatic notification of dead manifest situation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 260381
TreeView+ depends on / blocked
 
Reported: 2014-07-30 14:00 UTC by Dave Sullivan
Modified: 2019-08-15 03:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 14:23:35 UTC


Attachments (Terms of Use)

Description Dave Sullivan 2014-07-30 14:00:26 UTC
Description of problem:

It's possible to register a satellite server or any rhel box multiple times.

I figured subscription-manager would have corrected this, so it's also possible that a user may delete a validate satellite server in trying to clean up.

What I notice is that customer portal satellite server loses the manifest on delete of the satellite from within customer portal.

Then when you go into the Satellite and click referesh manifest you'll get an error.

Unless someone knows that the accidentally delete happened in the customer portal they may not ever refresh manifest.

So the request here is to have some auto health checks in place, like validate manifest is not dead, if it is then send appropriate emails.

The use case here is that when a manifest dies it's assumed that your schedules syncs will die to, but why not get the notification sooner that the manifest has died versus having to debug why syncs are failing.

There could be other use cases for general health check notifications.


Version-Release number of selected component (if applicable):


Sat6 beta

How reproducible:

see above

Additional Notes:

Fairly easy workaround of just deleting the manifest in UI.

Then going into customer portal and generating a new manifest and uploading that back into the Satellite6 server.

Comment 1 RHEL Product and Program Management 2014-07-30 14:24:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 8 Bryan Kearney 2016-07-08 20:24:00 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 10 Bryan Kearney 2017-05-30 14:23:35 UTC
Thank you for your interest in Satellite 6. We have evaluated this feature request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.