Bug 1124899 - openstack-glance should depend on python-oslo-vmware
Summary: openstack-glance should depend on python-oslo-vmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Flavio Percoco
QA Contact: Jaroslav Henner
URL:
Whiteboard:
Depends On: 1114623
Blocks: 1125876 1248434
TreeView+ depends on / blocked
 
Reported: 2014-07-30 15:06 UTC by Jaroslav Henner
Modified: 2016-04-26 18:51 UTC (History)
6 users (show)

Fixed In Version: openstack-glance-2014.1.1-2.el7ost.src.rpm
Doc Type: Bug Fix
Doc Text:
With this update, Image Service (glance) is now dependent on oslo.vmware in order to support the optional VMware store. This hard dependency was created due to the likelihood that the dependencies are already installed and due to the diminutive size of the package. As a result, the user experience is improved by no longer requiring a manual oslo.vmware install.
Clone Of:
: 1125876 (view as bug list)
Environment:
Last Closed: 2014-09-02 18:21:26 UTC
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1131 normal SHIPPED_LIVE openstack-glance bug fix advisory 2014-09-02 22:20:36 UTC

Description Jaroslav Henner 2014-07-30 15:06:23 UTC
Description of problem:
It may be good to install python-oslo-vmware with openstack-glance because of t he RHBZ#1114623.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:
packstack-deployed and hand reconfigured openstack-glance fails to start because of missing module

Expected results:
it started


Additional info:

Comment 2 Flavio Percoco 2014-07-31 06:30:21 UTC
I'm hesitant to make python-oslo-vmware a hard dependency because it's not enabled by default. I'm open to suggestions here.

@apevec we've had this kind of dilemmas with other packages, what do you recommend?

Comment 3 Alan Pevec 2014-07-31 08:27:25 UTC
Indeed, RPM is missing Suggests for optional dependencies, so they're left to the deployer or installer to take care of.

But strictly speaking, we should have Requires: python-FOO if we ship code which has "imports FOO" even if not loaded in the default configuration.

In this specific case, python-oslo-vmware runtime deps are nothing fancy, so it's fine to add it as a hard dep to openstack-glance.

Comment 6 Jaroslav Henner 2014-08-15 14:13:19 UTC
[root@jhenner-node-glance ~(keystone_admin)]# yum remove python-oslo-vmware
Loaded plugins: priorities
Resolving Dependencies
--> Running transaction check
---> Package python-oslo-vmware.noarch 0:0.3-3.el7ost will be erased
--> Processing Dependency: python-oslo-vmware for package: openstack-glance-2014.1.2-1.el7ost.noarch
--> Running transaction check
---> Package openstack-glance.noarch 0:2014.1.2-1.el7ost will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================
 Package                     Arch            Version                     Repository        Size
================================================================================================
Removing:
 python-oslo-vmware          noarch          0.3-3.el7ost                @puddle          172 k
Removing for dependencies:
 openstack-glance            noarch          2014.1.2-1.el7ost           @puddle           64 k

Transaction Summary
================================================================================================
Remove  1 Package (+1 Dependent package)

Installed size: 236 k

Comment 8 errata-xmlrpc 2014-09-02 18:21:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1131.html


Note You need to log in before you can comment on or make changes to this bug.