Bug 1124925 - File /var/run/docker.sock doesn't appear to have the correct group?
Summary: File /var/run/docker.sock doesn't appear to have the correct group?
Keywords:
Status: CLOSED DUPLICATE of bug 1119282
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 15:59 UTC by Sam Mingo
Modified: 2014-07-31 10:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 10:29:36 UTC


Attachments (Terms of Use)

Description Sam Mingo 2014-07-30 15:59:13 UTC
Description of problem: Cannot access the docker daemon using users that are members of the Unix group docker.


Version-Release number of selected component (if applicable):


How reproducible: Every time


Steps to Reproduce:
1. Do a install of docker-io
2. Confirm that user X is in the group "docker"
3. Confirm the default permissions

$ ls -l /var/run/docker.sock 
srw-rw----. 1 root root 0 Jul 29 18:19 /var/run/docker.sock

4. Try to run a docker command

$ docker images
2014/07/30 11:55:32 Get http:///var/run/docker.sock/v1.12/images/json: dial unix /var/run/docker.sock: permission denied


Actual results:

$ docker images
2014/07/30 11:55:32 Get http:///var/run/docker.sock/v1.12/images/json: dial unix /var/run/docker.sock: permission denied


Expected results:

Changing the permissions on the socket file fixes the issue.

$ sudo chgrp docker /var/run/docker.sock

$ ls -l /var/run/docker.sock 
srw-rw----. 1 root docker 0 Jul 29 18:19 /var/run/docker.sock

$ docker images
REPOSITORY          TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
pg-image            latest              1755abce241d        About an hour ago   319.5 MB
redis-image         latest              bef8689ea31c        About an hour ago   133.6 MB


Additional info:
Seems to be a packaging issue, perhaps in the .spec file?

I'm using the following version of docker-io

$ rpm -q docker-io
docker-io-1.0.0-6.fc20.x86_64

$ lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID:	Fedora
Description:	Fedora release 20 (Heisenbug)
Release:	20
Codename:	Heisenbug

Comment 1 Marek Goldmann 2014-07-31 10:29:36 UTC
Please upgrade to docker-io >= 1.0.0-9.

*** This bug has been marked as a duplicate of bug 1119282 ***


Note You need to log in before you can comment on or make changes to this bug.