Bug 112495 - ASUS P4S800-MX not recognised as SMP motherboard
ASUS P4S800-MX not recognised as SMP motherboard
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-21 03:38 EST by Peter Kiem
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 16:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested dmesg output (8.18 KB, text/plain)
2004-08-01 07:50 EDT, Peter Kiem
no flags Details

  None (edit)
Description Peter Kiem 2003-12-21 03:38:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Motherboard: ASUS P4S800-MX
Processor: Intel Pentium 4 2.66 GHz with 800 MHz FSB and hyperthreading
Memory: 1GB
Hardware Raid card: 3ware 7506-4LP
Drives: 4 x Seagate Barracuda ATA IV 80GB 7200 RPM

"Hyperthreading Technology" is enabled in the bios and bios boot
screen shows 2 Pentium 4 processors.

Installed Fedora Core 1 and both processors are recognised and appear
in top and /proc/cpuinfo

Installed RHEL ES 3 and only 1 processor is displayed in top and
/proc/cpuinfo.  Also noted a line "kernel: SMP motherboard not
detected" in /var/log/messages

The installer automatically selected and installed the SMP kernel.


/proc/cpuinfo contains
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.60GHz
stepping        : 9
cpu MHz         : 2600.781
cache size      : 512 KB
physical id     : 0
siblings        : 2
runqueue        : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmovpat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 5190.45

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. Check bios for hyperthreading technology enabled
2. Boot computer - Notice 2 processors reported
3. Install RHEL ES 3 via text mode
4. Boot using the default SMP kernel

Actual Results:  One processor listed in top and /proc/cpuinfo
syslog message of "kernel: SMP motherboard not detected"

Expected Results:  Two processors should be able to be seen and used.


Additional info:

Fedora Core 1 had no problems detecting the hyperthreading and
displaying 2 processors on the exact same hardware and bios settings.
Comment 2 Jim Paradis 2004-01-23 16:29:39 EST
I have a strong suspicion that this is a duplicate of Bug 112025, for
which there is a fix slated for U2.  
Comment 3 Jim Paradis 2004-05-21 15:30:59 EDT
To the original reporter: could you obtain the latest RHEL3 U2 kernel
via RHN and verify that this is indeed fixed?

Comment 4 Peter Kiem 2004-05-23 09:39:34 EDT
Now running 2.4.21-15.ELsmp obtained through up2date

Same deal :(  One CPU detected and the following line 
in /var/log/messages

May 23 23:34:51 caramon kernel: SMP motherboard not detected.

Same output from /proc/cpuinfo as well - 2 siblings detected.
Comment 5 Jim Paradis 2004-07-06 16:28:55 EDT
To the original reporter: could you do a "dmesg -s 65536" and attach
the result to this bug report?
Comment 6 Peter Kiem 2004-08-01 07:50:07 EDT
Created attachment 102339 [details]
Requested dmesg output

Now running the 2.4.21-15.0.3.ELsmp kernel
Comment 7 Christian P. MOMON 2005-01-20 17:07:23 EST
I have the same problem with a P4S800 motherboard (HyperThreading bios
 option enable).
When i boot on Knoppix 3.3 (Linux Knoppix 2.4.24-xfs #1 SMP Mi Feb 4
01:03:50 CET 2004 i686 GNU/Linux), i ses two CPU:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 9
cpu MHz         : 2400.118
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov 
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips        : 4784.12

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 9
cpu MHz         : 2400.118
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov 
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips        : 4797.23


But, with  Fedora Core 3 updated (last is Linux ocmstar
2.6.10-1.737_FC3 #1 Mon Jan 10 13:50:10 EST 2005 i686 i686 i386
GNU/Linu), the SMP version kernel stopping when it is booting (i can
press enter and flood the console but nothing else run). Nothing
special in the log. Any idea ?
Comment 8 Jim Paradis 2006-03-01 18:05:27 EST
Does this issue persist in the most current update?
Comment 10 Red Hat Bugzilla 2007-03-18 18:16:47 EDT
User jparadis@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.