Bug 1124970 - Merge upstream live merge fixes into 3.5 branch
Summary: Merge upstream live merge fixes into 3.5 branch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Adam Litke
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard: storage
: 1131548 (view as bug list)
Depends On:
Blocks: 1083310
TreeView+ depends on / blocked
 
Reported: 2014-07-30 18:44 UTC by Adam Litke
Modified: 2016-02-10 18:41 UTC (History)
12 users (show)

Fixed In Version: v4.16.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:22:39 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31045 ovirt-3.5 MERGED Live Merge: Add liveMerge capability to vdsCaps Never
oVirt gerrit 31046 ovirt-3.5 MERGED Live Merge: Explicitly save block job info Never
oVirt gerrit 31047 ovirt-3.5 MERGED Live Merge: Stop scanning volume chains at VM startup Never
oVirt gerrit 31048 ovirt-3.5 MERGED Live Merge: improve log messages Never
oVirt gerrit 31049 ovirt-3.5 MERGED Live Merge: Ignore libvirt block job events Never
oVirt gerrit 31050 ovirt-3.5 MERGED Live Merge: support active layer commit Never

Description Adam Litke 2014-07-30 18:44:40 UTC
After branching 3.5, some additional work to improve the Live Merge feature continued on the master branch.  In order to have a working version of Live Merge in the 3.5 release, these patches must be backported.

A non-exhaustive list of patches follows:
* Live Merge: support active layer commit
  - http://gerrit.ovirt.org/#/c/28598/ 
* Live Merge: Ignore libvirt block job events
  - http://gerrit.ovirt.org/#/c/30046/
* Live Merge: improve log messages
  - http://gerrit.ovirt.org/29310
* Live Merge: Stop scanning volume chains at VM startup
  - http://gerrit.ovirt.org/30045
* Live Merge: Explicitly save block job info
  - http://gerrit.ovirt.org/29358
* Live Merge: Add liveMerge capability to vdsCaps
  - http://gerrit.ovirt.org/28998

Comment 1 Vinzenz Feenstra [evilissimo] 2014-08-20 13:54:27 UTC
*** Bug 1131548 has been marked as a duplicate of this bug. ***

Comment 2 Sandro Bonazzola 2014-10-17 12:22:39 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.