Bug 1124974 - Typos in Installer Output
Summary: Typos in Installer Output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Installer
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: N. Harrison Ripps
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1124976
TreeView+ depends on / blocked
 
Reported: 2014-07-30 18:52 UTC by brice
Modified: 2015-05-15 02:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1124976 (view as bug list)
Environment:
Last Closed: 2014-07-31 18:20:12 UTC


Attachments (Terms of Use)

Description brice 2014-07-30 18:52:25 UTC
Description of problem:
There are two typos in the oo-install tool output.

In the broker configuration:
"Default Gear Capabilties for new users: |small|:"
(Capabilities)


In the node configuration:
"You have already desribed the following host system(s):"
(Described)


How reproducible:
Every time


Additional info:
I will note that this was installing the basic mode (all in one) version. While I'm sure the typos won't change, there's a chance there may be more if I went down a different path. I'll keep an eye out.

Comment 1 N. Harrison Ripps 2014-07-31 18:02:01 UTC
I found the second typo "desribed" but I cannot find "Capabilties" anywhere in the source code. Can you please provide the command that you used to run oo-install?

Comment 2 N. Harrison Ripps 2014-07-31 18:03:48 UTC
I think that "Capabilties" output is from the Enterprise version of oo-install, and I saw that you have a BZ open for that version. I will correct the first typo, however, as it is present in the Origin installer as well.

Comment 3 N. Harrison Ripps 2014-07-31 18:20:12 UTC
Fixed: https://github.com/openshift/openshift-extras/pull/424

Comment 5 N. Harrison Ripps 2014-08-26 13:09:01 UTC
The typo absolutely exists in OSE 2.1; here is the line with the "Capabilties" typo in the enterprise-2.1 branch of oo-install:

https://github.com/openshift/openshift-extras/blob/enterprise-2.1/oo-install/lib/installer/assistant.rb#L926

However, the typo does not exist in the enterprise-2.2 branch, nor in mainline (which is where the Origin version lives). I can't provide a link to a specific line because the code and textual output for that feature has been completely refactored from what existed in the OSE 2.1 version.


Note You need to log in before you can comment on or make changes to this bug.