Bug 1124977 - [RFE] hammer progress output should be more specific
Summary: [RFE] hammer progress output should be more specific
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1316598
Blocks: 1316897
TreeView+ depends on / blocked
 
Reported: 2014-07-30 19:08 UTC by Dave Sullivan
Modified: 2017-06-07 13:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 14:23:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4183 None None None 2016-07-28 11:05:20 UTC

Description Dave Sullivan 2014-07-30 19:08:11 UTC
Description of problem:

I am looking for some feature so when i run "katello -u admin -p admin system --instlal pkg1, pkg2, pkg3 --name sys1 --org test"

so rather then only showing task ID and that progress bar ..

i also want some activity like currently it's working on pkg1 and downloading it and installing it..

and if pkg2 is already installed? it shows that in output messages and if pkg3 fails it gives some reason of failure..

for users it's not good idea to always look for pulp.log to find out failure

also the task has limited information too ..

so it will be good idea to have above rather then just progress bar ..

http://projects.theforeman.org/issues/4183


Version-Release number of selected component (if applicable):

Satellite 6 Beta

How reproducible:

See example above

Comment 1 RHEL Product and Program Management 2014-07-30 19:13:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 7 Bryan Kearney 2016-08-10 16:02:51 UTC
Upstream bug component is Content Management

Comment 8 Bryan Kearney 2016-08-10 19:01:53 UTC
Upstream bug component is Hammer - Content

Comment 9 Bryan Kearney 2016-08-10 20:03:00 UTC
Upstream bug component is Content Management

Comment 10 Bryan Kearney 2016-08-10 22:02:49 UTC
Upstream bug component is Hammer - Content

Comment 12 Ivan Necas 2016-08-25 13:32:07 UTC
I think waiting for another provider for remote execution would be the right fix for this. I've added the dependency to the BZ tracking the non-ssh provider for REX.

Comment 13 Bryan Kearney 2017-05-30 14:23:17 UTC
Thank you for your interest in Satellite 6. We have evaluated this feature request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.