Bug 11250 - Install crashes during disk druid given error
Install crashes during disk druid given error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 14:53 EDT by P Jones
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 12:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2000-05-05 14:53:07 EDT
Asked for 1.15 TB for var, couldn't find the disk space (expected), clicked
next anyway. Locked up.
ALT-F1 reports:
Gtk-CRITICAL **: file gtkaccelgroup.c: line 188 (gtk_accel_group_attach):
assertion `g_slist_find (accel_group->attach_objects, object) ==NULL'
failed
Comment 1 Michael Fulbright 2000-06-12 15:20:05 EDT
Need test lab to verify.
Comment 2 Brock Organ 2000-06-15 13:56:00 EDT
hmm ... trying to reproduce the problem, I am unable to hang the install when
adding a 1.4 Gb /var to an already full disk ... I get the customary error
dialog and can proceed from there ...

what hardware are you using ...?  does this behave the same way in text mode
...?
Comment 3 P Jones 2000-07-13 18:25:43 EDT
This test was done on a IBM NetFinity 5100 w/ ServeRAID card.  Disk space was
probably upwards of 500GB online as a raid-5 array   I can recreate it here with
a NetFinity 4500R running at 4GB mem, and 138856 MB on IBM ServeRAID (IPS raid
driver).  I created the / and swap partitions at 1000MB and 100MB, and then put
1500000 for /var;  The message DOES come up that it couldn't allocate that
space, and I clicked OK.  The /var partition was red, but the >NEXT button was
NOT grey, and I pressed that and it died.  In text mode, I was given a Nice
warning that some partitions were not allocated, When I hit OK, the install then
got a sig 11.
Comment 4 Brock Organ 2000-11-01 16:20:16 EST
reassigning these to dale@redhat.com for further review ...
Comment 5 Dale Lovelace 2000-11-02 15:08:53 EST
I can successfully reproduce this here in the lab. The "Next" button is not
greyed out, so you may proceed without fixing the unallocatable /var partition.
You must already have a correctly allocated / and swap partition though, or the
button will be greyed out.
Comment 6 P Jones 2000-11-06 14:27:11 EST
Note: effect verified on version 7.0
Comment 7 Michael Fulbright 2001-01-11 15:58:54 EST
Think I have a fix for this in our internal tree - needs to be tested.
Comment 8 Brock Organ 2001-01-17 12:31:15 EST
this issue is handled more gracefully, if not optimally, in the test tree
qa0116.3.  Previously, an unallocated partition in ddruid would cause a fatal
error during formatting of partitions; the current behavior is to create
successfully allocated partition, but to NOT create unsuccessfully allocated
partitions.  

However, this issue is not handled optimally, since a user who creates an
unallocated partition is not warned of the unallocated open issue ...thanks for
your report!
Comment 9 Brock Organ 2001-01-17 12:32:29 EST
deferring for a more optimum solution (w/including warning message to the user
when unallocated partitions exist upon exiting disk druid...) ...
Comment 10 Michael Fulbright 2001-09-14 12:37:17 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.