Bug 112503 - latest flash plugin not working in mozilla 1.4.1
latest flash plugin not working in mozilla 1.4.1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-21 11:08 EST by David Bentley
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 20:46:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bentley 2003-12-21 11:08:40 EST
Description of problem:

Having installed the Macromedia flash plugin as described by
Macromedia in the \usr\lib\mozilla-1.4.1 directory the two expected
components are installed as expected (flashplayer.xpt and
libflashplayer.so) but the browser still has no flash functionality
nor is the plugin shown when you check for it in Help about plugins.

The instalation was done as root and therefore should be globally
availabe.

Prior to installing the flash plugin I have installed the latest sun
java runtime with no problem and just to see if this was causing the
problem I removed the java functionality by temporarily deleting the
required symbolic link in \usr\lib\mozilla\plugins but after
re-downloading an re-installing the flash plugin it is still not
recognized by the browser and therefore still doesn't work.

Version-Release number of selected component (if applicable):

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031114

Shockwave Flash 6.0 r79

How reproducible:

see problem description

Steps to Reproduce:
1.install following instructions provided
2.
3.
  
Actual results:

install claims to be successful and the requisite files appear where
expected

Expected results:

flash plugin being visible in Help about plugins (but it isn't) and
sites that should use the plugin still display the jigsaw symbol

Additional info:

none
Comment 1 Kai Thomsen 2003-12-23 12:34:09 EST
The plug-in was compiled for an older version of the Standard C++ 
Library. You need to install the package "compat-libstdc++".

The official Flash Player 6 packages from http://macromedia.mplug.
org/ know about the exact library requirements.
Comment 2 David Bentley 2003-12-23 15:12:19 EST
I have been to http://macromedia.mplug.org/ and downloaded the RPM
version for fedora core 1 and installed it and everything now works as
it should. 

The one that I had downloaded before from a link within the normal
macromedia site http://www.macromedia.com and following the shortcut
Download Flash Player only offers what appears to be the generic
version  of the plugin (which bye the way works fine in Red Hat 9)
Comment 3 Kai Thomsen 2003-12-23 16:40:51 EST
Just to clarify, the plug-in contained in the RPM package does not 
differ from the version downloadable from macromedia.com.  The 
package contains some custom scripts, though, which automate (de-)
installation and upgrades.

The "compat-libstdc++" package is needed in Red Hat Linux 9, too, but 
it's apparently part of the common installation types.
Comment 4 Jan Machac 2003-12-28 15:09:53 EST
OK, the plugin is installed, loaded, working... But the sound is
missing...

When I try to play any .swf with sound I get only ticking... Always
the same ticking... But for examle xmms works fine and on my previous
system  (Mandrake 9.2) everything worked fine (Mozilla 1.3.x and the
same plugin...)

Is that only my problem??

Can I fix it??

I'm not an experienced user, so please help me ;-)
Comment 5 Warren Togami 2004-01-28 20:46:01 EST
Jan Machac your sound problem is probably symptomatic of your sound
driver which can either play only one PCM stream at once, or is buggy
in some other way.  There are unfortunately limitations in sound
capability in Linux.  In any case this is NOTABUG for mozilla.

Note You need to log in before you can comment on or make changes to this bug.