Bug 1125032 - python-basemap cannot be imported in epel6
Summary: python-basemap cannot be imported in epel6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-basemap
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 22:51 UTC by Gregory Hennessy
Modified: 2015-04-23 18:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-23 14:56:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 842870 None None None Never

Internal Links: 842870

Description Gregory Hennessy 2014-07-30 22:51:34 UTC
Description of problem: Importing basemap fails


Version-Release number of selected component (if applicable): 6.5


How reproducible: Very

Steps to Reproduce:
1. start python
2. type "from mpl_toolkits import basemap"
3. watch error messages

Actual results: Failed with error message:
raceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/mpl_toolkits/basemap/__init__.py", line 38, in <module>
    import pyproj, sys, os, math, dbflib
  File "/usr/lib64/python2.6/site-packages/mpl_toolkits/basemap/pyproj.py", line 48, in <module>
    from _proj import Proj as _Proj
  File "c_numpy.pxd", line 76, in _proj (src/_proj.c:3234)
ValueError: numpy.dtype does not appear to be the correct type object
>>> 



Expected results: basemap would be imported


Additional info: This seems to be a recurrence of Bug 842870

Comment 1 Orion Poplawski 2015-04-22 22:42:55 UTC
What versioin of numpy, and from where?

Comment 2 Orion Poplawski 2015-04-22 22:50:00 UTC
I'll note that it works for me with numpy 1.4.1 from RHEL6.

Comment 3 Greg Hennessy 2015-04-23 14:35:09 UTC
root@gsh-vm ~]# yum list | grep numpy
This system is not registered with RHN Classic or RHN Satellite.
You can use rhn_register to register.
RHN Satellite or RHN Classic support will be disabled.
numpy.x86_64                       1.4.1-9.el6          @rhel-x86_64-workstation-6
numpy-f2py.x86_64                  1.4.1-9.el6          @rhel-x86_64-server-6

Comment 4 Orion Poplawski 2015-04-23 14:39:12 UTC
Can you report:

python
import numpy as np
print np.__version__

rpm -V numpy

Comment 5 Greg Hennessy 2015-04-23 14:42:07 UTC
(In reply to Orion Poplawski from comment #2)
> I'll note that it works for me with numpy 1.4.1 from RHEL6.

I deleted numpy via yum remove basemap, and then reinstalled, and it works.

Comment 6 Greg Hennessy 2015-04-23 14:48:52 UTC
This bug can be closed in my opinion.

Comment 7 Orion Poplawski 2015-04-23 14:56:26 UTC
Thanks.  Be aware that if you do package installs with pip as root it will overwrite the rpm installed versions.

Comment 8 Greg Hennessy 2015-04-23 16:19:19 UTC
(In reply to Orion Poplawski from comment #7)
> Thanks.  Be aware that if you do package installs with pip as root it will
> overwrite the rpm installed versions.

I try very hard not to use PIP unless there isn't a RPM available.

Comment 9 Orion Poplawski 2015-04-23 16:54:22 UTC
That's good.  Just trying to throw out possible methods of corruption.

Comment 10 Greg Hennessy 2015-04-23 18:30:38 UTC
(In reply to Orion Poplawski from comment #9)
> That's good.  Just trying to throw out possible methods of corruption.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.