Bug 1125034 - import --verbose emits *everything*, even if --debug is not set
Summary: import --verbose emits *everything*, even if --debug is not set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Grant Gainey
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-30 22:52 UTC by Grant Gainey
Modified: 2014-09-11 12:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:29:51 UTC


Attachments (Terms of Use)

Description Grant Gainey 2014-07-30 22:52:16 UTC
The way logging should work:

--quiet == "nothing to stdout"
--debug == "emit debug stmts"
--verbose == "if you're going to emit it, emit it to stdout as well"

progress always goes to stdout unless --quiet
info, warn, error, fatal go to logfile
debug should only happen if you ask for it

Current behavior:
--verbose causes --debug to emit

Expected behavior:
--verbose emits to stdout, but debug-output only emits if --debug

Comment 1 RHEL Product and Program Management 2014-07-30 23:13:36 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Grant Gainey 2014-07-31 15:48:05 UTC
commit 1383d2049435db34c9d1bc92424b72902c67f172

Comment 7 Bryan Kearney 2014-09-11 12:29:51 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.