Bug 1125054 - Anaconda segfault if HP NC380T HBA/NIC is present
Summary: Anaconda segfault if HP NC380T HBA/NIC is present
Keywords:
Status: CLOSED DUPLICATE of bug 1036881
Alias: None
Product: Fedora
Classification: Fedora
Component: 0ad
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://www.dropbox.com/s/6mw0ykajtsb...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 01:23 UTC by Kodiak Firesmith
Modified: 2014-07-31 12:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 12:25:59 UTC


Attachments (Terms of Use)
Image of failure (2.33 MB, image/jpeg)
2014-07-31 01:25 UTC, Kodiak Firesmith
no flags Details

Description Kodiak Firesmith 2014-07-31 01:23:41 UTC
User-Agent:       Mozilla/5.0 (X11; Linux) AppleWebKit/538.1 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/538.1 Midori/0.5
Build Identifier: 

Anaconda segfaults at loading broadcom offload iscsi initators with "segfault at 0 ip <string> sp <string> error 4 in liniscsi.so.0<string>"

Full details in pic linked above.


Reproducible: Always

Steps to Reproduce:
1. Boot Fedora 20 install DVD with HP NC380T card present
2. Get "dead pane" message before GUI anaconda loads
3. Switch to console and observe the events that lead up to the anaconda segfault
Actual Results:  
Dead install

Expected Results:  
Anaconda working

Do the build w/o the card present, then install the card to work around.  Card works fine after install.  

This could be a bummer for any user who doesn't realize what is breaking the install.  It's not immediately obvious without knowing where to look and interpreting that the card is causing Anaconda to segfault.

Comment 1 Kodiak Firesmith 2014-07-31 01:25:51 UTC
Created attachment 922775 [details]
Image of failure

This is what appears on the console if the card is present.

Comment 2 David Shea 2014-07-31 12:25:59 UTC
This is a bug in iscsi-initiator-utils

*** This bug has been marked as a duplicate of bug 1036881 ***


Note You need to log in before you can comment on or make changes to this bug.