Bug 112507 - Sendmail SMTP AUTH fails
Sendmail SMTP AUTH fails
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-12-21 15:32 EST by Corey Head
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-12-30 16:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Corey Head 2003-12-21 15:32:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I have set up sendmail authentication on previous releases or Redhat
(notably 8 and 9) with absolutely no problems.  I followed the
guidelines offered here at 


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Follow link provided above.
2.  Try to send mail with a client setup with SMTP Authentications
3.  BINGO!

Actual Results:  Client can't authenticate.  It just gets
asked/re-asked for its password over and over.  This shows up in the
maillog when client finally stops trying to send.

Dec 21 11:34:48 fresca sendmail[16571]: aldfjdsakfjadkjdf:
[] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

Expected Results:  Client will authenticate and send mail to expected

Additional info:

This method has worked perfectly until now with Enterprise ES 3. 
Clients are set up correctly, sendmail is set up correctly.  Either
sasl or pam are not cooperating and I can't figure out which.  I have
added the /etc/pam.d/smtp file as well as the
/usr/lib/sasl/Sendmail.conf and /usr/lib/sasl/smtpd.conf files.  Still
the same results after restarting services.  I noticed 8.12.10 uses
sasldb2 instead of sasldb.  However, adding the Sendmail.conf and
smtpd.conf files to usr/lib/sasl2 seemed to do nothing different.
Comment 1 Corey Head 2003-12-21 21:48:49 EST
Oops!  Noticed a typo in the link.  Here's the right one...

Comment 2 Jaanus J6gisman 2003-12-29 14:29:56 EST
exactly same problem here.
using sendmail 8.12.10-1.1.1
worked before on RH9 with sendmail 8.12.8
Comment 3 Jaanus J6gisman 2003-12-29 15:17:16 EST
well, found out what was causing the problem..
saslauthd was not running :P
/etc/init.d/saslauthd start
fixed the problem for me

Comment 4 Corey Head 2003-12-30 16:57:53 EST
I did have saslauthd running, but the problem ended up being that cyrus-sasl-devel 
package was not installed at initial installation.  It only gets installed if you choose the 
"Development" packages.  I also updated to the 2.1.17 sasl2 libs.  Between the two of 
them, I stopped getting the "unknown password verifier" error message in the 
messages log.  So...it's up and running now.  Perhaps making the cyrus-sasl-devel 
packages install with sendmail would be a good idea?
Comment 5 Thierry Bagnoud 2004-04-13 06:27:12 EDT
I have installed sendmail-8.12.11-3 ( src file ) ( found in
http://people.redhat.com/twoerner/SRPMS/3.0E/ )

After buiding the package, the SMTP_AUTH with pam doesn't work.

The link /etc/pam.d/smtp -> /etc/alternatives/mta-pam doesn't exist.

If I create this link, SMTP_AUTH with pam work.


Note You need to log in before you can comment on or make changes to this bug.