Bug 1125086 - samba uses libsystemd-daemon.so instead of the new libsystemd.so
Summary: samba uses libsystemd-daemon.so instead of the new libsystemd.so
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1338768 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 04:01 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2017-08-08 11:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 11:47:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Samba Project 10672 None None None Never

Description Zbigniew Jędrzejewski-Szmek 2014-07-31 04:01:42 UTC
Description of problem:
samba-libs uses '-lsystemd-daemon' but should switch to '-lsystemd'.
This causes it to require systemd-compat-libs, containing systemd libraries with historical names.

For longer explanation see http://www.spinics.net/lists/fedora-devel/msg200853.html.

Version-Release number of selected component (if applicable):
samba-libs-2:4.1.9-3.fc21.x86_64

Comment 1 Alexander Bokovoy 2014-07-31 04:25:03 UTC
We are tracking the same issue upstream with https://bugzilla.samba.org/show_bug.cgi?id=10672

Comment 2 Fedora End Of Life 2015-11-04 15:16:38 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Jan Kurik 2016-02-24 13:15:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 4 Zbigniew Jędrzejewski-Szmek 2016-05-23 12:46:41 UTC
*** Bug 1338768 has been marked as a duplicate of this bug. ***

Comment 5 Andreas Schneider 2016-05-24 07:43:50 UTC
We have a policy at Red Hat/Fedora: Upstream first!

So please create an upstream bug or submit the patch to samba-technical!

Comment 6 Jan Pazdziora 2016-05-24 07:49:35 UTC
(In reply to Andreas Schneider from comment #5)
> 
> So please create an upstream bug or submit the patch to samba-technical!

Comment 1 suggests it's actually been in upstream since 2014, as https://bugzilla.samba.org/show_bug.cgi?id=10672 which was closed as dupe of https://bugzilla.samba.org/show_bug.cgi?id=11200.

Comment 7 Alexander Bokovoy 2016-05-24 07:56:08 UTC
This bug should be closed as it was reported in Fedora 21 and is not relevant for Fedora 24.

Comment 8 Jan Pazdziora 2016-05-24 07:58:51 UTC
FWIW, I confirm that samba-client-libs-4.4.3-1.fc25.2.x86_64 from http://koji.fedoraproject.org/koji/buildinfo?buildID=767901 no longer fails with

Error: Package: 2:samba-client-libs-4.4.3-1.fc25.1.x86_64 (rawhide)
           Requires: libsystemd-daemon.so.0(LIBSYSTEMD_DAEMON_31)(64bit)
Error: Package: 2:samba-client-libs-4.4.3-1.fc25.1.x86_64 (rawhide)
           Requires: libsystemd-daemon.so.0()(64bit)

Comment 9 Jan Pazdziora 2016-05-24 08:00:30 UTC
Actually, it became very relevant in rawhide where systemd-compat-libs seems to no longer exist.

Comment 10 Alexander Bokovoy 2016-05-24 08:26:19 UTC
Here is the problem: we have an alternative patch proposed upstream since February 2016 that simply makes up old defines in case only libsystemd is found and makes it a preferable one.

https://github.com/samba-team/samba/pull/53/commits/3ce7adb6945c9913f8aa48043f2e23ac5e04bba6

But we don't have a patch from Zbigniew proposed upstream. This is what Andreas was talking about.

I'd rather to see the patch from Zbigniew sent upstream because it allows us to support both old and new version with less code changes.

Comment 12 Zbigniew Jędrzejewski-Szmek 2016-05-24 13:43:04 UTC
My knowledge about samba and about waf is nonexistent. I pushed a quick-fix patch that makes a minimum change to allow samba to compile, but I'd prefer if one of the maintainers of the package decided if this is the right fix and maybe pushed it upstream.

Comment 13 Andreas Schneider 2016-05-24 14:44:49 UTC
Your patch looks correct and as Alexander already said he likes your approach. However you should first send the patch for discussion upstream and make sure it gets fixed. We do not want to carry a fix which upstream is not accepted.

As this is already in the Fedora package now, please go ahead and send it upstream from inclusion. git format-patch is preferred with your Signed-Off :)

Comment 14 Fedora End Of Life 2017-07-25 18:41:30 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 15 Fedora End Of Life 2017-08-08 11:47:54 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.