Bug 11251 - NE2000 isn't recognized by installer
NE2000 isn't recognized by installer
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 15:59 EDT by Ed Friedman
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 13:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2000-05-05 15:59:12 EDT
Back in version 5.0, the ne2000 clone NIC cards were recognized perfectly
during installation.  In 5.1 through 6.0, they were only recognized when
they had IRQ=3.  Since 6.1, they are not being recognized at all.  Under
6.2, when I tried to have the installer use the ne2000 card, I received the
error message:  /tmp/ne.o: init _module: Device or resource busy
After the installation, if I add the lines:

alias eth0 ne
options ne io=0x300

then the card is recognized during startup and everything works fine after
I manually modify the associated files that would have automatically been
set up properly if the card had been recognized.

Ed Friedman
ed@math.uchicago.edu
Comment 1 Brock Organ 2000-06-15 13:59:20 EDT
hmmm ... were you unable to specify the proper module parameters during the
install ...?
Comment 2 Brock Organ 2000-06-15 14:01:56 EDT
did you verify the BIOS settings for your motherboard to ensure that the PnP
settings/ISA slot settings were appropriately set ...?
Comment 3 Ed Friedman 2000-06-15 15:07:03 EDT
I tried specifying the address (0x300) and the IRQ (3), but I still received the
identical error message during installation.  The card was set jumperless, not
PnP, and post installation, everything worked perfectly after I put the proper
lines into /etc/conf.modules

The BIOS was set for PNP OS = N, and the ISA slot settings were normal.

I am dealing with NE2000 clones here, not "real" NE2000's, but the installation
used to work perfectly in older versions of RedHat on the very same machines
which now must be configured post-installation.
Comment 4 Michael Fulbright 2000-10-04 14:48:43 EDT
There are lots of NE2000 variants out there - this may just be something the
kernel driver is not handling correctly.

Give 7.0 a try and let us know if its better.
Comment 5 Brock Organ 2000-11-02 13:58:16 EST
Hi Ed,

we could not reproduce that behavior here in test (although, given the number of
ne2k variants, that certainly doesn't mean your behavior didn't occur :) ) ...
we were able to use our ne2k clone after specifying both io addr (0x300) & irq
(3) ... it also doesn't help that both the cards & the machines they tend to be
installed in are aging, and not always gracefully! :(

I'm not able to determine whether you're particular card is flaky, or whether
some subset of ne2k clones DO have troubles ...!  I would be very interested to
know whether you had success with other cards in this machine, and also whether
or not you had additional cards of this manufacturer & model, and if they worked
for you ...

thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.