Bug 1125108 - Stopping docker service unmounts btrfs filesystem
Summary: Stopping docker service unmounts btrfs filesystem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1128041
Blocks: 1109938
TreeView+ depends on / blocked
 
Reported: 2014-07-31 04:34 UTC by Avi Miller
Modified: 2019-03-06 01:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Avi Miller 2014-07-31 04:34:22 UTC
Description of problem:

If you put /var/lib/docker on a btrfs filesystem, Docker switches to using the btrfs storage engine. However, if you stop the docker service, it unmounts /var/lib/docker which means if you start it again, the btrfs filesystem is gone and it switches to using device-mapper on the wrong filesystem.

Version-Release number of selected component (if applicable):

docker-0.11.1-22.el7

How reproducible:

100%

Steps to Reproduce:
1. Create a btrfs filesystem
2. Mount the btrfs filesystem on /var/lib/docker
3. Start docker
4. Check the storage engine is btrfs via "docker info"
5. Stop docker

Actual results:

btrfs filesystem at /var/lib/docker is unmounted

Expected results:

btrfs filesystem should remain mounted after docker stops.

Additional info:

None.

Comment 2 Daniel Walsh 2014-07-31 13:21:35 UTC
I believe this is fixed in docker-1.1-2

Comment 3 Luwen Su 2014-08-06 10:04:05 UTC
It's okay for me if does it without selinux in docker-1.1.2-6.el7.x86_64, but i still want to keep the bug status as the scenario lack of selinux supporting.
https://github.com/docker/docker/pull/6452/files

Comment 5 errata-xmlrpc 2014-09-18 20:46:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.