Bug 1125117 - bind vnet devices on different namespaces
Summary: bind vnet devices on different namespaces
Keywords:
Status: CLOSED DUPLICATE of bug 636146
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 05:10 UTC by gustavo panizzo <gfa>
Modified: 2016-04-10 19:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-10 19:18:23 UTC


Attachments (Terms of Use)

Description gustavo panizzo <gfa> 2014-07-31 05:10:04 UTC
Description of problem:

i would like if libvirt could bind vnet devices on different namespaces

i would like to segment different bridges (linux bridges) on namespaces. so i can, for example, put all vm connected to certain vlan, and the bridge where them connect, on a specific namespace.
i would ideally create as many namespaces as vlans.

that should be a configuration option, off by default. 

    <interface type='bridge'>
      <mac address='52:54:00:10:e9:e3'/>
      <source bridge='br0'/>
      <target dev='vnet0'/>
      <namespace='foo'/>
    </interface>


i would set this bug as wishlist item.

thanks

Comment 1 gustavo panizzo <gfa> 2014-07-31 05:15:07 UTC
in this example, libvirt should look for bridge br0 on namespace named foo, admin should take care of create bridge and namespace. i any of them does not exist virsh start should fail

Comment 2 gustavo panizzo <gfa> 2014-07-31 05:15:40 UTC
s/i any/if any/

Comment 3 Cole Robinson 2016-04-10 19:18:23 UTC
I think this would be solved/integrated as part of a larger effort to containerize VMs, which is a broader topic for which an RFE already exists

*** This bug has been marked as a duplicate of bug 636146 ***


Note You need to log in before you can comment on or make changes to this bug.