Bug 1125156 - Error notifications should not be popped up on top menus
Summary: Error notifications should not be popped up on top menus
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 08:22 UTC by Sachin Ghai
Modified: 2019-04-01 20:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-21 07:38:59 UTC


Attachments (Terms of Use)
Error notification hides top right menus (41.30 KB, image/png)
2014-07-31 08:22 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6865 None None None 2016-04-22 15:51:01 UTC

Description Sachin Ghai 2014-07-31 08:22:28 UTC
Created attachment 922853 [details]
Error notification hides top right menus

Description of problem:
I was trying some boundary value testing with defined param under setiings--> General.

So I changed the value of "entries_per_page" param to '0', and UI throws an error. And that error message actually hides top right menus( Admin user and Administer). Please see screenshot.

Our automation actually failing because of this issue.
Reason: Once the test is executed with one data set, UI logged out but here since the notification hiding the top right menu, so logout doesn't work as selenium is unable to select the logged user menu.

We have a workaround, when the error notification raised, we can close it before logout. But it would be great if we can fix it in product as well. Thanks

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Error notifications should not hide top menus

Additional info:

Comment 2 Dominic Cleal 2014-07-31 13:12:14 UTC
Created redmine issue http://projects.theforeman.org/issues/6865 from this bug

Comment 3 Tomer Brisker 2016-04-21 07:38:59 UTC
After discussion with UX it was agreed that moving the notifications down will lead to different issues and would not be an improvement overall. Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.