Bug 1125166 - Current implementation depends on Intel's SSE2 extensions
Summary: Current implementation depends on Intel's SSE2 extensions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1140845
TreeView+ depends on / blocked
 
Reported: 2014-07-31 08:38 UTC by Xavi Hernandez
Modified: 2015-05-14 17:42 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1140845 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2014-07-31 08:38:53 UTC
Description of problem:

Currently EC xlator uses inline assembler and makes use of XMM registers of Intel's SSE2 extensions.

This is not portable and should be converted to standard C.

Version-Release number of selected component (if applicable): 3.6


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-08-04 19:14:17 UTC
REVIEW: http://review.gluster.org/8413 (ec: Removed SSE2 dependency) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-09-08 11:20:42 UTC
REVIEW: http://review.gluster.org/8413 (ec: Removed SSE2 dependency) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2014-09-12 05:44:34 UTC
COMMIT: http://review.gluster.org/8413 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 26be0b3a9f334f33f1a6e53706045eb02983d713
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Mon Aug 4 20:50:31 2014 +0200

    ec: Removed SSE2 dependency
    
    This patch implements the Galois Field multiplications using pure C
    code without any assembler support. This makes the ec xlator portable
    to other architectures.
    
    In the future it will be possible to use an optimized implementation
    of the multiplications using architecture dependent facilities (it
    will be automatically detected and configured). To allow bricks with
    different machine word sizes to be able to work seamlessly in the
    same volume, the minimum fragment length to be stored in any brick
    has been fixed to 512 bytes. Otherwise, different implementations
    will corrupt the data (SSE2 used 128 bytes, while new implementation
    would have used 64).
    
    This patch also removes the '-msse2' option added on patch
    http://review.gluster.org/8395/
    
    Change-Id: Iaf6e4ef3dcfda6c68f48f16ca46fc4fb61a215f4
    BUG: 1125166
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8413
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:26:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.