Bug 1125174 - [RFE] Support IdM running in FIPS-140 mode
Summary: [RFE] Support IdM running in FIPS-140 mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
Marc Muehlfeld
URL:
Whiteboard:
: 1308973 1364196 (view as bug list)
Depends On: 1380393 1400149 1401606 1411428 1412211 1436657
Blocks: 1396494 1399979 1341621 1411849 1411858 1427443
TreeView+ depends on / blocked
 
Reported: 2014-07-31 08:54 UTC by Martin Kosek
Modified: 2018-12-04 17:57 UTC (History)
28 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: Release Note
Doc Text:
Identity Management now supports FIPS With this enhancement, Identity Management (IdM) supports the Federal Information Processing Standard (FIPS). This enables you to run IdM in environments that must meet the FIPS criteria. To run IdM with FIPS mode enabled, you must set up all servers in the IdM environment using Red Hat Enterprise Linux 7.4 with FIPS mode enabled. Note that you cannot: * Enable FIPS mode on existing IdM servers previously installed with FIPS mode disabled. * Install a replica in FIPS mode when using an existing IdM server with FIPS mode disabled. For further details, see https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html-single/Linux_Domain_Identity_Authentication_and_Policy_Guide/index.html#prerequisites.
Clone Of:
: 1341621 1427443 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:37:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC
Red Hat Bugzilla 1131570 None None None 2019-08-30 09:33:34 UTC
Red Hat Bugzilla 1131571 None None None 2019-08-30 09:33:34 UTC

Internal Links: 1131570 1131571

Description Martin Kosek 2014-07-31 08:54:55 UTC
Description of problem:
Identity Management in RHEL-7.0 does not work well with FIPS mode, several issues were reported in RHEL-6.6 testing:

- ipa-client-install fails unless /etc/pki/nssdb/ is properly pre-configured. This should be fixed either by Bug 852023 or upstream ticket https://fedorahosted.org/freeipa/ticket/4140

- FIPS mode needs to be enabled manually for Apache mod_nss

- user-show SSH pubkey processing reports Internal Error in FIPS mode (user-show SSH pubkey processing crashes in FIPS mode)

- PKI does not return expected results on certificate requests


To support FIPS mode properly, IPA will need to be able to:
1) Detect when running in FIPS mode
2) Update appropriate configuration if needed
3) Fall back in functions that use unsupported crypto

Comment 2 Martin Kosek 2014-08-19 15:11:44 UTC
Until we decide to support running in FIPS mode (when there is a value), we decided to at least give clear error message before installation or starting IPA services that it does not run in FIPS mode.

RHEL-6.7: Bug 1131571
RHEL-7.1: Bug 1131570

Comment 5 Petr Vobornik 2016-02-23 17:51:58 UTC
*** Bug 1308973 has been marked as a duplicate of this bug. ***

Comment 10 Petr Vobornik 2016-08-04 16:59:40 UTC
*** Bug 1364196 has been marked as a duplicate of this bug. ***

Comment 16 Martin Bašti 2017-01-12 10:11:21 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/721105c53de6fbc0abc7799ec7f48920e02089bd

Comment 17 Petr Vobornik 2017-01-12 12:10:06 UTC
For composing future release notes:

Commit in comment 16 is changing a way how SSH Pub Keys Fingerprints are generated. Fingerprint is changed to be a sha256 hash instead of MD5 hash.

Comment 26 Petr Vobornik 2017-04-04 08:16:30 UTC
Moving to modified state. This was practically implemented in 4.5. 

Note there is a know bug which will be fixed in bug 1438679

Comment 28 Abhijeet Kasurde 2017-05-22 13:13:14 UTC
Verified using IPA version :: ipa-server-4.5.0-13.el7.x86_64

Test area covered following things - 
1. Basic IPA Master, Replica and Client installation with FIPS enabled
2. Replica Promotion related scenarios
3. Sub CA related scenarios
4. Backup and restore scenarios
5. CA-less related scenarios
6. KRA related scenarios
7. Client with and without FIPS installation
8. Vault related scenarios
9. With Domain level 0
10. Help and man page verification

Test coverage will also covers - 
1. Keycloak
2. Windows AD related scenarios
3. Smart Card

Comment 29 Martin Kosek 2017-05-26 09:40:22 UTC
Please note that Red Hat officially released public RHEL-7.4 Beta this week, as announced here:
https://www.redhat.com/en/about/blog/red-hat-enterprise-linux-74-beta-now-available

The new RHEL-7.4 release includes a lot of new IdM functionality, including this RFE. Highlights can be found in RHEL-7.4 Release Notes, especially in the Authentication & Interoperability chapter:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7-Beta/html/7.4_Release_Notes/new_features_authentication_and_interoperability.html

IdM Engineering team would like to encourage everyone interested in this new functionality (and especially customers or community members requesting it) to try Beta and provide us with your feedback!

Comment 32 errata-xmlrpc 2017-08-01 09:37:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.