Bug 1125180 - [SNAPSHOT] Snap mount doesn't inheret mount options from parent brick
Summary: [SNAPSHOT] Snap mount doesn't inheret mount options from parent brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1124583
Blocks: 1145088
TreeView+ depends on / blocked
 
Reported: 2014-07-31 09:11 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:47 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1124583
: 1145088 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-07-31 09:12:51 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2014-07-31 09:15:42 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2014-07-31 09:24:29 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2014-08-01 11:14:10 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2014-08-01 11:47:49 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Anand Avati 2014-08-01 12:18:14 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Anand Avati 2014-08-03 14:28:30 UTC
REVIEW: http://review.gluster.org/8394 (glusterd/snapshot:  Inherit the mount options of a original brick when creating snapshots) posted (#7) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 8 Anand Avati 2014-08-03 14:28:58 UTC
COMMIT: http://review.gluster.org/8394 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 8080a5555e7ba17b9e691171259899ca9e390c76
Author: Vijaikumar M <vmallika@redhat.com>
Date:   Thu Jul 31 14:37:19 2014 +0530

    glusterd/snapshot:  Inherit the mount options of a original brick
    when creating snapshots
    
    When creating a snapshot a LVM is created at the backend and is mounted
    under /var/run/gluster/snaps/... However, this mount does not inherit
    the mount options for the original brick acting as the parent for the
    snap.
    
    If the snap is restored, this could lead to performance degredations,
    functional limitations, or in extreme scenarios even potential data
    loss.
    
    Change-Id: I67d70fd83430d83dacc5380c6c928e27fb9c9e1b
    BUG: 1125180
    Signed-off-by: Vijaikumar M <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/8394
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 9 Niels de Vos 2015-05-14 17:26:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:43:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.