Bug 1125184 - Updates of KieContainer works only for first declared KieContainer based component
Summary: Updates of KieContainer works only for first declared KieContainer based comp...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Rules / jBPM integration
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 6.1.0
Assignee: David Virgil
QA Contact: Tomas Rohovsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 09:23 UTC by Tomas Rohovsky
Modified: 2016-05-09 01:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-14 17:12:30 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTESB-3629 Major Closed Updates of KieContainer works only for first declared KieContainer based component 2018-02-14 15:30:37 UTC
JBoss Issue Tracker SWITCHYARD-2240 Major Resolved Updates of KieContainer works only for first declared KieContainer based component 2018-02-14 15:30:37 UTC

Description Tomas Rohovsky 2014-07-31 09:23:09 UTC
Updates of a KieContainer works only for first KieContainer based component declared in the switchyard.xml. Every next KieContainer based component is not updated.

I have tested that with Rules. It is not possible to test that with BPM because it does not work for any (even the first declared component) - SWITCHYARD-2228.

A reproducer is attached in JIRA. Run it by mvn verify.

Comment 1 tcunning 2015-07-14 17:12:30 UTC
We are starting to use JIRA for tracking issues for Fuse 6.2.1.    I've logged https://issues.jboss.org/browse/ENTESB-3629 to track this issue.   Closing this bugzilla and work will continue on the associated JIRA.

Comment 2 JBoss JIRA Server 2015-07-24 15:07:23 UTC
Tom Cunningham <tcunning@redhat.com> updated the status of jira ENTESB-3629 to Resolved

Comment 3 JBoss JIRA Server 2015-11-30 11:23:06 UTC
Tomas Rohovsky <trohovsk@redhat.com> updated the status of jira ENTESB-3629 to Closed


Note You need to log in before you can comment on or make changes to this bug.