Bug 112523 - Unhelpful error message when installing packages
Summary: Unhelpful error message when installing packages
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-22 06:22 UTC by abp
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 20:23:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description abp 2003-12-22 06:22:39 UTC
Description of problem:

The error message displayed in Gnome GUI after the system fails to
install an RPM package gives no indication as to where the problem lies.

Version-Release number of selected component (if applicable):

Fedora 1

How reproducible:

Attempt to install a package from Gnome GUI.  Used default
desktop/workstation installation of Fedora 1.

Steps to Reproduce:
1. Menu -> System Settings -> Add/Remove Applications
2. Select any packages
3. Attempt to install
  
Actual results:

Window pops up titled "Error installing packages".  Window body reads
"There was an error installing packages."
"Exiting."

Expected results:

Information regarding which error occured.  E.g. could not read
installation media, media device (CD-ROM, diskette drive, etc) not
found, user selected non-existent package, etc.

Additional info:

This bug report does not regard the fact that the package installation
failed -- that's either an error on my part or a different bug.  But
it's difficult to decide which (or whether it's a problem specific to
the Gnome package installer) if I can't figure out what the problem is.

Comment 1 abp 2003-12-22 06:37:32 UTC
*abp 12/21 After running redhat-config-packages in a terminal window
it appears that the package installation failure has same cause as bug
109276.  (redhat-config-packages expects path directory /RedHat where
it should expect /Fedora.)


Comment 2 Jeremy Katz 2005-09-21 20:23:27 UTC
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.


Note You need to log in before you can comment on or make changes to this bug.