Bug 1125252 (sat6-dupeprofile) - [Duplicate Hosts] Reprovisioning the host causes to create new content host
Summary: [Duplicate Hosts] Reprovisioning the host causes to create new content host
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: sat6-dupeprofile
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1132363
TreeView+ depends on / blocked
 
Reported: 2014-07-31 12:34 UTC by Ivan Necas
Modified: 2017-02-23 21:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-08 07:02:21 UTC


Attachments (Terms of Use)

Description Ivan Necas 2014-07-31 12:34:02 UTC
Steps to Reproduce:
1. provision a host with activation key
2. after provisioning finishes (and the content host is registered), rebuild the system (Build button + restart of the host)
3. after the re-provisioning happens, the are two content hosts with the same fqdn

Expected results:
Either the content host is unregistered on the re-provisioning or the existing content host is reused at the second time (ideally letting the user to choose
which option they want)

Comment 1 RHEL Product and Program Management 2014-07-31 12:44:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Stephen Benjamin 2014-08-21 11:38:22 UTC
This causes you not to be able to rebuild a host when you are out of valid subscriptions as well.

How Foreman handles Puppet CA may be interesting to look at.  When a host requests a provisioning template -- i.e. we know we are *really* rebuilding the host -- they revoke the old key and create a new one.  Maybe have it fire off a dynflow action to do something similar to the attached content host.

Comment 6 Brad Buckingham 2014-09-04 20:54:39 UTC
I believe the changes introduced with Katello PR https://github.com/Katello/katello/pull/4555 (bug 1122736) will address the behavior observed.

With the new behavior, when a content-host is registered, if there is an existing host (w/ same name+mac) and if that host already has a content-host associated, the existing content-host will be deleted and a new one created & associated.

If that is sufficient to address this bug, we can probably close this one as a duplicate or move to ON_QA for testing.

Comment 7 Ivan Necas 2014-09-08 07:02:21 UTC
The chnages description really looks like it should handle this situation. Closing. Will reopen if there is something missing that this BZ requires. Thanks for info


Note You need to log in before you can comment on or make changes to this bug.