Bug 1125290 - fence_virt can return 0 on failure
Summary: fence_virt can return 0 on failure
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-virt
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 13:50 UTC by Jaroslav Kortus
Modified: 2015-07-22 07:32 UTC (History)
5 users (show)

(edit)
Previously, the fence-virt utility in some case incorrectly returned a zero exit code when it detected an error in processing a request. With this update, the static analysis errors that caused this problem have been fixed, and fence-virt now returns appropriate error codes if it detects an error.
Clone Of:
(edit)
Last Closed: 2015-07-22 07:32:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1401 normal SHIPPED_LIVE fence-virt bug fix and enhancement update 2015-07-20 18:07:19 UTC

Description Jaroslav Kortus 2014-07-31 13:50:01 UTC
Description of problem:
fence_virt can return 0 even though it detected an error on processing the request

Version-Release number of selected component (if applicable):
fence-virt-0.2.3-18.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. fence_virt -H xxxxx -t 1; echo $?
2.
3.

Actual results:
[root@virt-136 pengine]# fence_virt -H xxxxx -t 1; echo $?
vmchannel connect: Connection timed out
Failed to connect to 10.0.2.179:1229
0


Expected results:
[root@virt-136 pengine]# fence_virt -H xxxxx -t 1; echo $?
vmchannel connect: Connection timed out
Failed to connect to 10.0.2.179:1229
0 <-- non-zero exit code should be displayed here


Additional info:

Comment 2 Ryan McCabe 2014-09-15 15:16:29 UTC
This has already been fixed upstream in commit

commit f7ccaa261a83505118b735067846f17bde12430c
Author: Lon Hohberger <lon@users.sourceforge.net>
Date:   Tue Sep 20 11:40:39 2011 -0400

    Fix static analysis errors
    
    Signed-off-by: Lon Hohberger <lon@users.sourceforge.net>

Comment 7 errata-xmlrpc 2015-07-22 07:32:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1401.html


Note You need to log in before you can comment on or make changes to this bug.