Bug 1125291 - Red Hat channels are not visible after inter-satellite sync
Summary: Red Hat channels are not visible after inter-satellite sync
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 1027335
TreeView+ depends on / blocked
 
Reported: 2014-07-31 13:51 UTC by Jiří Mikulka
Modified: 2014-10-06 13:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 07:54:09 UTC


Attachments (Terms of Use)

Description Jiří Mikulka 2014-07-31 13:51:56 UTC
Description of problem:
Inter-satellite synchronization between two Satellite 5.7 does not correctly synchronize all channels. Custom channels are correctly synchronized together with all packages/rpms/... into the correct organization (as specified in organization mapping). The problem is with all Red Hat (base/child) channels - packages/rpms/... are correctly synchronized and stored in /var/satellite/redhat/NULL/ but no channels are created on the slave Satellite.

Version-Release number of selected component (if applicable):
spacewalk-backend-2.2.43-1.el6.noarch (tested on Spacewalk 2.2)

How reproducible:
always

Steps to Reproduce:
1. prepare master and slave Satellite 5.7 (Spacewalk 2.2 respectively)
2. on master: create some custom channels and synchronize some Red Hat channels
3. on master/client: set up the ISS
4. on slave: synchronize all channels from the master

Actual results:
only custom and cloned Red Hat channels are synchronized

Expected results:
all channels are synchronized

Additional info:

Comment 1 Jiří Mikulka 2014-08-01 07:54:09 UTC
My bad, I didn't realize that the slave Satellite 5.7 (Spacewalk 2.2) has to be registered/activated against Hosted before ISS setup/sync. So the behaviour is correct - non-registered/activated Satellite can show only non-Red Hat channels.

Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.