Bug 1125296 - Generate doxygen documentation
Summary: Generate doxygen documentation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libteam
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Pirko
QA Contact: Zhenjie Chen
URL:
Whiteboard:
Depends On: 1116970
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 13:57 UTC by Joe Lawrence
Modified: 2015-05-05 01:25 UTC (History)
5 users (show)

Fixed In Version: libteam-1.12-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 08:16:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
Generated doxygen doc file (73.16 KB, application/x-xz)
2015-01-22 03:05 UTC, Jaye Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0332 normal SHIPPED_LIVE libteam bug fix and enhancement update 2015-03-05 12:28:06 UTC

Description Joe Lawrence 2014-07-31 13:57:13 UTC
Description of problem:

Source header files contain doxygen style comments, but the documentation is not generated by the build.

Comment 3 Jiri Pirko 2014-08-18 20:51:20 UTC
Another upstream commit needed:
https://github.com/jpirko/libteam/commit/332dc54e8f59a9ca794bb3a90791af084fa44f74

Comment 6 Jaye Zhang 2015-01-22 03:05:56 UTC
Created attachment 982576 [details]
Generated doxygen doc file

Reproduced on libteam-1.9:

There is NO any documentation about doxygen-style.


Verified on libteam-1.15:

$ cd libteam-1.15/
$ ./autogen.sh && ./configure && make
$ cd doc/
$ doxygen Doxyfile

Generated doxygen doc file successfully: libteam-1.15/doc/api

Comment 7 Jaye Zhang 2015-01-22 03:15:51 UTC
According to Comment 6, set to VERIFIED.

Comment 8 Jaye Zhang 2015-01-22 03:38:22 UTC
just a supplement:

$ doxygen -v
1.8.5

Comment 10 errata-xmlrpc 2015-03-05 08:16:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0332.html


Note You need to log in before you can comment on or make changes to this bug.