Bug 1125300 - Can not migrate or create an application in another domain using --from-app command
Summary: Can not migrate or create an application in another domain using --from-app c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 14:03 UTC by Eric Rich
Modified: 2015-05-15 02:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:50:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1140043 None None None Never

Description Eric Rich 2014-07-31 14:03:52 UTC
Description of problem:

$ --> rhc app create prod_app -n gsscloud --from-app dev_app
Application 'dev_app' not found.

How reproducible: Very

Steps to Reproduce:
1. rhc app create prod_app -n production --from-app dev_app

Additional info:

$ --> rhc domain list
Domain development (owned by User)
-------------------------------------------------
  Created:            Feb 20, 2013 11:07 PM
  ID:                 DOMAIN_ID
  Allowed Gear Sizes: small, medium, large

Domain production (owned by User)
---------------------------------------------
  Created:            Jun 04  2:49 PM
  ID:                 DOMAIN_ID
  Allowed Gear Sizes: small
  Members:            user1@domain.com (edit)

Comment 1 Fabiano Franz 2014-07-31 21:28:31 UTC
When you provide -n it will be used as the domain for both the original app and the one being created. To clone an app between domains you have to use the slash syntax, as in 'domain/app'. Example:

rhc app create dest_app -n dest_domain --from-app original_domain/original_app

So in your case, if I got it right:

rhc app create prod_app -n production --from-app gsscloud/dev_app

Does that fixes the issue?

(In reply to Eric Rich from comment #0)

Comment 2 Eric Rich 2014-08-01 12:48:08 UTC
When I tested this, it seemed to work on the first try, however it failed. 

It looks as though it failed because in my gsscloud namespace I had a prod_app already defined. So it error'ed with: 

> Creating application 'prod_app' ... DNS entry not found

Deleting this in the gsscloud namespace, allowed me to create it in the production namesapace! 

So there seems to be a check (with DNS) on the names you are choosing which could block someone from competing this action if they us the same name between two namespaces.


Note You need to log in before you can comment on or make changes to this bug.