Bug 1125312 - Disperse xlator issues in a 32 bits environment
Summary: Disperse xlator issues in a 32 bits environment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1144407
TreeView+ depends on / blocked
 
Reported: 2014-07-31 14:28 UTC by Xavi Hernandez
Modified: 2015-05-14 17:43 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1144407 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:26:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1146903 None None None Never

Internal Links: 1146903

Description Xavi Hernandez 2014-07-31 14:28:11 UTC
Description of problem:

EC xlator doesn't work correctly when compiled with 32 bits.

Version-Release number of selected component (if applicable): master


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-09-15 10:02:59 UTC
REVIEW: http://review.gluster.org/8738 (ec: Fix some size_t vars to 64 bits even on 32 bits machines) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Anand Avati 2014-09-19 07:54:38 UTC
REVIEW: http://review.gluster.org/8738 (ec: Fix some size_t vars to 64 bits even on 32 bits machines) posted (#2) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 3 Anand Avati 2014-09-19 10:02:51 UTC
COMMIT: http://review.gluster.org/8738 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f32378b660dab5f3f311da8252969a7da16898f4
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Mon Sep 15 11:57:43 2014 +0200

    ec: Fix some size_t vars to 64 bits even on 32 bits machines
    
    The 64 bits 'trusted.ec.size' extended attribute was incorrectly
    computed on 32 bits machines due to an overflow on negative
    numbers.
    
    Also changed some potentially dangerous uses of size_t in other
    places.
    
    Change-Id: Id76cfe49a2f350e564b5c71d8c8644fb9ce86662
    BUG: 1125312
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/8738
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:26:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:43:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.