Bug 1125321 - rubygem-staypuft: The networker host in the deployment wasn't send to reboot, I had to manually reboot the host to finish the deployment.
Summary: rubygem-staypuft: The networker host in the deployment wasn't send to reboot,...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-foreman-tasks
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 14:55 UTC by Omri Hochman
Modified: 2015-04-29 14:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 14:49:51 UTC


Attachments (Terms of Use)
production.log (1.39 MB, text/x-log)
2014-07-31 14:55 UTC, Omri Hochman
no flags Details

Description Omri Hochman 2014-07-31 14:55:05 UTC
Created attachment 922957 [details]
production.log

rubygem-staypuft: The networker host in the deployment wasn't send to reboot, I had to manually reboot the host to finish the deployment.

It's not always reproducible:
I've done nonHA-neutron-vxlan deployment, After the controller got to 100%, the second host (networker) was hang in the discovery-image and I needed to manually reboot the networker host in order to finish the deployment. 

environment:
------------
puppet-3.6.2-1.1.el6.noarch
puppet-server-3.6.2-1.1.el6.noarch
openstack-puppet-modules-2014.1-19.8.el6ost.noarch
ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch
foreman-1.6.0.21-2.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el6sat.noarch
foreman-postgresql-1.6.0.21-2.el6sat.noarch


(attached production.log)

Comment 3 Petr Chalupa 2014-08-08 11:05:30 UTC
The problem is that the API for restarting the host is not reporting success or failure so Staypuft cannot detect failure. It would need to be fixed in foreman-discovery, see https://github.com/theforeman/foreman_discovery/blob/develop/app/models/host/managed_extensions.rb#L16-L25


Note You need to log in before you can comment on or make changes to this bug.