Bug 1125327 - For Foreman task unassociated with a deployment, NIL error3
Summary: For Foreman task unassociated with a deployment, NIL error3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 15:06 UTC by Jason E. Rist
Modified: 2014-08-21 18:07 UTC (History)
4 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:07:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Jason E. Rist 2014-07-31 15:06:07 UTC
Description of problem:
When trying to populate a deployment with hosts, there is a corner case where a task might not be associated with a deployment, causing a no method error.

`undefined method `resource_id' for nil:NilClass`

Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1. In development mode, attempt to populate a deployment with hosts
2. Get redirected to a foreman task error
NoMethodError in Foreman_tasks/tasks#show

Showing /home/jrist/workspace/foreman/vendor/ruby/1.9.1/gems/foreman-tasks-0.6.6/app/views/foreman_tasks/tasks/show.html.erb where line #65 raised:
3. ???

Actual results:


Expected results:
No error, hosts populate fine.

Additional info:

Comment 1 Jason E. Rist 2014-07-31 15:07:38 UTC
Fix pending: https://github.com/theforeman/staypuft/pull/245

Comment 3 Jason E. Rist 2014-07-31 15:25:02 UTC
Note, my steps easily recreated this in development mode, but this may show up in non-development mdoe as well

Comment 4 Scott Seago 2014-07-31 15:40:15 UTC
PR pushed to master.

Comment 8 Omri Hochman 2014-08-07 13:01:32 UTC
unable to reproduce ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch

Comment 9 errata-xmlrpc 2014-08-21 18:07:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.