Bug 11254 - Jaz drive fails (advansys complaints) with 2.2.14-12 kernel
Jaz drive fails (advansys complaints) with 2.2.14-12 kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 16:45 EDT by jpeek
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-07 17:40:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jpeek 2000-05-05 16:45:38 EDT
I have a Jaz drive (via SCSI) on my system.  It's worked fine under Red Hat
6.1.  I upgraded to 6.2 (from the Red Hat official CD-ROM) and it worked
fine.  Then I upgraded my kernel to the latest from the website,
2.2.14-12.  Now I get these errors as I boot (the first two aren't errors):

VFS: mounted root (ext2 filesystem).
Loading advansys module
/lib/advansys.o: unresolved symbol scsi_register_Rb13032eb
/lib/advansys.o: unresolved symbol best_memcpy_Ra0b82c11
/lib/advansys.o: unresolved symbol scsi_unregister_R84f2a037
/lib/advansys.o: unresolved symbol proc_print_scsidevice_Rbcfeb0c9
/lib/advansys.o: unresolved symbol best_memset_R3e04c7a1

Then, later, Kudzu says that "Iomega jaz 1GB" has been removed from my
system.  And, if I try to mount the drive anyway (from a shell prompt), I
get:

# mount /mnt/jaz
mount: the kernel does not recognize /dev/jaz as a block device.

Tech support suggested I submit a bug report.

I can still boot from my old kernel 2.2.14-5.0 (which I saved, luckily).
Comment 1 Doug Ledford 2000-05-07 17:40:59 EDT
You need to remake your initrd image after upgrading your kernel and then rerun
lilo (these are documented kernel upgrade procedures).  Your module won't load
because you are trying to load the module from 2.2.14-5.0 in the 2.2.14-12
kernel.
Comment 2 Craig Lawson 2001-03-12 17:58:12 EST
I have this same problem with Red Hat 7.0. I remade my initrd kernel image, and
it did not help at all. I see similar errors when I boot (scsi_unregister_...,
proc_print_scsidevice_..., and scsi_register_... are unresolved). Unfortunately,
these message do not appear in the boot log, and it took several reboots to
transcribe the information.

Although the advansys module fails to load during boot, I can load it later with
modprobe, and then mount will work.

As far as I am concerned, this bug is still open.
Comment 3 Craig Lawson 2001-03-15 02:03:40 EST
My mistake! I thought my lilo.conf referenced kernel images consistently, but
actually it was not. I remade my initrd image, corrected lilo.conf, and then
everything worked smoothly.

I am embarrassed. Can I remove my name from this bug? Hopefully this information
will be cleaned out in a few months....

Note You need to log in before you can comment on or make changes to this bug.