Bug 11255 - Old SPARC 2 SCSI error
Old SPARC 2 SCSI error
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: silo (Show other bugs)
6.2
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
http://www.tux.org/hypermail/linux-ke...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 17:30 EDT by Barry Simmons
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-06 18:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Simmons 2000-05-05 17:30:32 EDT
I have a SPARCStation 2 and I have been unable to get 2.2.1.45 to boot
after install.
I repartitioned with fdisk s on both SCSI drives and everything installed
fine from the SCSI CD.
After install I get the following

esp0: IRQ 3 SCSI ID 7 Clk 20 MHz CCF=4 TOut 167 NCR53C90A (esp100a)
ESP: Total of 1 ESP hosts found, 1 actually in use
scsi0: Sparc ESP100A (NCR53C90A)
scsi: 1 host
esp0: Warning, live target 0 not responding to selection

This last message keeps running and until I press stop A
Comment 1 Barry Simmons 2000-05-05 17:51:59 EDT
Re: 2.2.x fails to boot on SPARC 2 (scsi problems)
David S. Miller (davem@redhat.com)
Fri, 7 May 1999 18:43:40 -0700
Maybe in reply to: Max: "2.2.x fails to boot on SPARC 2 (scsi problems)"
Date: Fri, 7 May 1999 11:19:12 -0700
From: Max <maxk@chinook.stanford.edu>

I would be very surprised to hear that compiler choice matters.

Believe it or not we had to fix a problem exactly like this in the
2.0.x Sparc kernels, in exactly the ESP driver, and exactly because
egcs was being used as the compiler instead of gcc.


The issue back then, was that egcs would move some memory references
around (in a legal way, was not a compiler bug) that on slower
machines would cause a race condition which would confuse the ESP
driver and make it barf on disks that normally acted correctly.


I am not saying we are certainly hitting the same issue here, but when
I read your report, bells went off in my head and this is why I
instantly asked what compiler you were using.


I've also been told by a couple people that they were able to solve
this problem by either getting a new drive or playing around with
the cables and termination. Something somewhere in the new esp.c
is probing something that esp.c under 2.0.x didn't.


If you do resolve the issue in this way, please let me know, because I
still consider the bug open at this point.


Later,
David S. Miller
davem@redhat.com


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/



Next message: Aziwoqpd: "more FAT32 driver annihilated my filesystem...all
before noon (fwd)"
Previous message: Uwe Bonnes: "[Patch] Get consistent disk paging data
with /proc/stat"
Maybe in reply to: Max: "2.2.x fails to boot on SPARC 2 (scsi problems)"
Comment 2 Barry Simmons 2000-05-06 18:05:59 EDT
RESOLVED by fiddling with SCSI settings.
Faulty Matrox SCSI drive perhaps ?
Disconnected first drive and reran install with no problems

Note You need to log in before you can comment on or make changes to this bug.