Bug 1125556 - staypuft sets wrong backend for glance backend ceph
Summary: staypuft sets wrong backend for glance backend ceph
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Installer
Assignee: Scott Seago
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 01:34 UTC by Mike Burns
Modified: 2014-08-21 18:07 UTC (History)
4 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:07:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Mike Burns 2014-08-01 01:34:37 UTC
Description of problem:
When choosing ceph as the glance, this error occurs on HA controller:

Unsupported backend ceph at /etc/puppet/environments/production/modules/quickstack/manifests/glance.pp:134 on node mac525400a8b9d7.staypuft.local

The correct backend is rbd when ceph is chosen

Version-Release number of selected component (if applicable):
0.1.999.1

How reproducible:
Always

Comment 1 Mike Burns 2014-08-01 01:58:31 UTC
since this is a simple bug, also:

pcmk fs manage should be true for file based, but false in other cases.  it's currently true with ceph.

Comment 2 Scott Seago 2014-08-01 02:13:41 UTC
Fix in PR: https://github.com/theforeman/staypuft/pull/247

Comment 3 Scott Seago 2014-08-01 02:42:10 UTC
PR merged

Comment 6 nlevinki 2014-08-07 09:24:28 UTC
change glance_backend = rbd fron glance_backend=file.
they change was successful without any error.

Comment 7 errata-xmlrpc 2014-08-21 18:07:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.