Bug 112562 - db4 isn't compatible with DCTC
db4 isn't compatible with DCTC
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: db4 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-22 16:33 EST by Marcin Garski
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-23 09:23:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Garski 2003-12-22 16:33:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.4.1)
Gecko/20031010

Description of problem:
db4 that is in RHL 9 cause DCTC (a Direct Connect clone, you can get
it from: http://ac2i.homelinux.com/dctc/) to crash.

When i run DCTC i've got following messages:
[marcin@drosera i386]$ dctc -g 192.168.2.36
INFO ] ""Direct Connect Text Client v0.85.7|
hubip: 192.168.2.36 hubport: 411
Using 192.168.35.152 as localhost IP.
ERR  ] ""No client capabilities set: default to '/CAPAB MD4x'.|
setsock or bind: Permission denied
[repeated many times]
setsock or bind: Permission denied
VAR  ] ""cnx_status|1|
file exists.
current sema found.
DCTC: db_appinit, open /home/marcin/.dctc/bDB fails: Function not
implemented

Other users of RHL 9 have the same problem, but if they install db4
from RHL 8.0, or recompile db4 from source DCTC work fine.

You can find more information under this addresses:
http://brainz.servebeer.com/phpBB2/viewtopic.php?t=286
http://brainz.servebeer.com/phpBB2/viewtopic.php?t=179
http://brainz.servebeer.com/phpBB2/viewtopic.php?t=165

Version-Release number of selected component (if applicable):
db4-4.0.14-20

How reproducible:
Always

Steps to Reproduce:
1. Download DCTC source
2. Compile it
3. Run DCTC
4. Watch the errors

Actual Results:  DCTC crash

Expected Results:  DCTC should be working :)

Additional info:
Comment 1 Jeff Johnson 2003-12-22 17:42:16 EST
Is this build problem or install problem?

If build, you need to fix your build for db-4.2.52.

If install, then you need to install compat-db-4.1.25.

Which is it?
Comment 2 Jeff Johnson 2003-12-22 17:43:38 EST
Hmmm, sorry, it's the same issue with db-4.1.25 in RHL 9
as well. If build, you need to fix your build, if install,
you need cpmpat-db-4.0.14.
Comment 3 Marcin Garski 2003-12-22 19:17:16 EST
It isn't build problem nor install.
I can compile and install DCTC without any errors, warnings and problems.
The problem occur when i'am try to run DCTC (it show messages that i
mention already "DCTC: db_appinit, open /home/marcin/.dctc/bDB fails:
Function not implemented").
This problem appear only in RHL 9 with shipped db4 RPM.

Beside in RHL 9 the only available version of db4 is db4-4.0.14-20.
Comment 4 Jeff Johnson 2003-12-22 21:03:38 EST
"Function not implemented" smells a lot like
you are running a non-nptl kernel and hence missing
certain (optional) pthread routines.

What kernel? What glibc? Where did they come from?

Reading the bugs indicates that a recompile of
db4 "works". That's prolly all that can be done
for an unsupported package like dctc. Have you tried
recompiling db4 from the src.rpm?
Comment 5 Marcin Garski 2003-12-23 09:23:36 EST
I'm running on home-made 2.4.22 kernel (vanilla + XFS), glibc is
2.3.2-27.9.7 (from RHL 9 update).

I've found what cause this problem, you are right that is NPTL :)
If i back to distro kernel (with NPTL) without changing db4, or
recompile db4 from src.rpm without --enable-posixmutexes (i've comment
this line) but with new kernel 2.4.22 (without NPTL) DCTC works fine.

Thanks for help (and aiming me at NPTL) !!!

Note You need to log in before you can comment on or make changes to this bug.