Bug 11257 - Partitionless install weirdness
Partitionless install weirdness
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 17:45 EDT by marty
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 15:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marty 2000-05-05 17:45:33 EDT
Once the size of the redhat.img file created reaches 2,147,483,647 bytes
the installation fails with an anaconda error:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 342, in ?
    intf.run(todo, test = test)
  File "/usr/lib/anaconda/text.py", line 1165, in run
    rc = apply (step[1](), step[2])
  File "/usr/lib/anaconda/text.py", line 702, in __call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 1112, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/usr/lib/anaconda/fstab.py", line 428, in mountFilesystems
    isys.ddfile("/mnt/loophost/redhat.img", self.loopbackSize)
  File "/usr/lib/anaconda/isys.py", line 52, in ddfile
    _isys.ddfile(fd, megs)
SystemError: (2, 'No such file or directory')
Comment 1 marty 2000-05-08 09:52:59 EDT
To be more clear, choosing a value greater than 2047 MB for the / filesystem
fails.
Comment 2 Jay Turner 2000-05-10 15:37:59 EDT
Yes, this is because of the 2G partition size limit for DOS filesystems.  So,
basically this is a limitation of the underlying FAT32 filesystem and has
nothing to do with the linux installation.  We will have a limiter in the next
release to prevent users from breaking this barrier . . . just didn't think
about it for this release.
Comment 3 jszabo 2000-05-13 16:41:59 EDT
fat32 can be greater than 2G
fat16 cannot

Note You need to log in before you can comment on or make changes to this bug.