Bug 1125796 - "Guest moved used index from 10122 to 10253" when reboot win2012R2 guest with 129 virtio-scsi target
Summary: "Guest moved used index from 10122 to 10253" when reboot win2012R2 guest with...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: pre-dev-freeze
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 04:57 UTC by Qunfang Zhang
Modified: 2015-11-24 08:43 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:43:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Qunfang Zhang 2014-08-01 04:57:22 UTC
Description of problem:
Boot a win2012r2 guest with 256 virtio-scsi target (1 controller, 1 LUN), and then reboot guest, qemu quit with "Guest moved used index from 10122 to 10253". Boot up with 1 scsi target, no problem. 

Version-Release number of selected component (if applicable):
kernel-2.6.32-491.el6.x86_64
qemu-kvm-0.12.1.2-2.432.el6.x86_64
virtio-win-prewhql-87 (for virtio-scsi driver)

How reproducible:
Always

Steps to Reproduce:
1. # cat 256-target.sh 
cli="/usr/libexec/qemu-kvm -machine rhel6.6.0,dump-guest-core=off -m 24G -smp 12 -cpu Westmere -vnc :10 -vga std -monitor stdio -boot menu=on -monitor unix:/tmp/monitor,server,nowait -drive file=/root/scalability/win2012-r2.qcow2,if=none,id=blk1 -device virtio-blk-pci,scsi=off,drive=blk1,id=blk-disk1,bootindex=1 -netdev tap,id=netdev1,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=netdev1,mac=02:03:04:05:06:00,id=net-pci1"
cli="$cli -device virtio-scsi-pci,id=scsi0"
count=$((${1:-1}-1))
for i in $(seq 0 $count)
do
echo $i
 cli="$cli -drive file=/home/disk/disk$i,if=none,id=disk$i"
 cli="$cli -device scsi-hd,bus=scsi0.0,drive=disk$i,id=target$i,scsi-id=$i,lun=0"
done
$cli

# sh 256-target.sh 256

2. Check whether the 256 scsi disk could be detected and used.

3. Reboot guest

Actual results:
After step 3:
(qemu) Guest moved used index from 10122 to 10253/etc/qemu-ifdown: could not launch network script

Expected results:
Guest should reboot successfully

Additional info:

Comment 2 Qunfang Zhang 2014-08-01 07:30:45 UTC
This bug could be reproduced on qemu-kvm-0.12.1.2-2.432.el6.x86_64 with >= 129 virtio scsi target. 
Also test the rhel6.5 released version qemu-kvm-0.12.1.2-2.415.el6.x86_64 with 129 and 130 virtio scsi target, can not reproduce. So this should be a regression.

Comment 4 Fam Zheng 2014-08-06 00:55:13 UTC
Qunfang, can you reproduce with 433 or later? It has a new fix on virtio-scsi (bug 1123698).

Please test with the latest build if possible.

Thanks,
Fam

Comment 5 Qunfang Zhang 2014-08-07 03:26:02 UTC
(In reply to Fam Zheng from comment #4)
> Qunfang, can you reproduce with 433 or later? It has a new fix on
> virtio-scsi (bug 1123698).
> 
> Please test with the latest build if possible.
> 
> Thanks,
> Fam

Hi, Fam

I just tested qemu-kvm-0.12.1.2-2.435.el6.x86_64, this issue still exists. 

Thanks,
Qunfang

Comment 6 Qunfang Zhang 2014-08-07 03:47:51 UTC
Can not reproduce this issue with a RHEL6.6 guest.

Comment 10 Fam Zheng 2014-08-08 08:04:43 UTC
Changing component to RHEL 7 virtio-win since the real fix is in windows virtio-scsi driver.

Comment 11 Fam Zheng 2014-08-08 08:05:42 UTC
Close since the bug is fixed in latest virtio-win build as comment 9.

Comment 12 Mike Cao 2014-08-08 08:27:40 UTC
(In reply to Fam Zheng from comment #11)
> Close since the bug is fixed in latest virtio-win build as comment 9.

This build hasn't shipped to customers ,pls keep this bug open

Comment 13 Mike Cao 2014-08-08 08:28:17 UTC
Change status to Verified based on comment #9

Comment 15 Fam Zheng 2014-11-13 01:28:51 UTC
Mike, would you please take care of this bug's erratum accordingly, or maybe close it if there is already a bug for the virtio-win update?

Thanks,
Fam

Comment 16 Mike Cao 2014-11-13 02:04:55 UTC
(In reply to Fam Zheng from comment #15)
> Mike, would you please take care of this bug's erratum accordingly, or maybe
> close it if there is already a bug for the virtio-win update?
> 
> Thanks,
> Fam

Virtio-win is something complex compared w/ other component ,it contains 3 component ,namely ,virtio-win, virtio-win-prewhql, qemu-ga-win , we ship virtio-win at last ,

Actually This bug is fixed on virtio-win-prewhql-89 build ,but the fix does not plan to included in virtio-win yet that's why we did not add the bug to advisory 

I will take care of this bug when developer make the decision (add it to erratum or propose to next release althrough it is in ON_QA/VERIFIED status

Mike

Comment 21 errata-xmlrpc 2015-11-24 08:43:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.