Bug 1125810 - virt-who show "TypeError" when it run at libvirtd mode
Summary: virt-who show "TypeError" when it run at libvirtd mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 05:58 UTC by Liushihui
Modified: 2016-12-01 00:33 UTC (History)
3 users (show)

Fixed In Version: virt-who-0.10-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:13:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1513 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2014-10-14 01:22:23 UTC

Description Liushihui 2014-08-01 05:58:52 UTC
Description of problem:
Configure virt-who run at libvirtd mode, then run virt-who, it will show "TypeError: registerCloseCallback() takes exactly 3 arguments (4 given)" when it communication with virtualization backend

Version-Release number of selected component (if applicable):
subscription-manager-1.12.10-1.el6.x86_64
python-rhsm-1.12.5-1.el6.x86_64
virt-who-0.10-4.el6.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6.4-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Register system to SAM server.
2. Configure virt-who run at libvirtd mode 
VIRTWHO_DEBUG=1
VIRTWHO_BACKGROUND=1
VIRTWHO_INTERVAL=5
3. Restart virt-who service
4. Check the virt-who log at /var/log/rhsm/rhsm.log

Actual results:
It will show error message as the following:
2014-08-01 13:52:12,432 [INFO]  @virtwho.py:438 - No configurations found, using libvirt as backend
2014-08-01 13:52:12,433 [DEBUG]  @virtwho.py:170 - Starting infinite loop with 2 seconds interval
2014-08-01 13:52:12,537 [DEBUG]  @libvirtd.py:80 - Starting libvirt monitoring event loop
2014-08-01 13:52:12,552 [ERROR]  @virtwho.py:118 - Error in communication with virtualization backend, trying to recover:
Traceback (most recent call last):
  File "/usr/share/virt-who/virtwho.py", line 111, in _send
    virtualGuests = self._readGuests(config)
  File "/usr/share/virt-who/virtwho.py", line 143, in _readGuests
    virt.startMonitoring(self.sync_event)
  File "/usr/share/virt-who/virt/libvirtd/libvirtd.py", line 150, in startMonitoring
    monitor.check()
  File "/usr/share/virt-who/virt/libvirtd/libvirtd.py", line 81, in check
    self._loop_start()
  File "/usr/share/virt-who/virt/libvirtd/libvirtd.py", line 67, in _loop_start
    self._create_connection()
  File "/usr/share/virt-who/virt/libvirtd/libvirtd.py", line 72, in _create_connection
    self.vc.registerCloseCallback(self._close_callback, None, None)
TypeError: registerCloseCallback() takes exactly 3 arguments (4 given)
2014-08-01 13:52:12,563 [DEBUG]  @libvirtd.py:131 - Virtual machine found: 6.5_Server_x86_64: 79d3879f-3b54-81da-0e22-78a88e90bdcf
2014-08-01 13:52:12,566 [DEBUG]  @libvirtd.py:137 - Virtual machine found: 6.5_Client_i386: a9b6f4db-8f8d-cc12-52c3-2d198673ebc4
2014-08-01 13:52:12,568 [DEBUG]  @libvirtd.py:137 - Virtual machine found: 5.10_Server_x86_64: fe493d82-513d-f969-8e1b-7c11c88945e0
2014-08-01 13:52:12,570 [DEBUG]  @libvirtd.py:137 - Virtual machine found: 6.4_Server_x86_64: ce0a9a54-fa57-0920-8b57-dc61ab7f90cb
2014-08-01 13:52:12,572 [DEBUG]  @libvirtd.py:137 - Virtual machine found: 7.0_Server_x86_64: 73629554-e7e5-552c-42b9-e58575ee2427

Expected results:
It shouldn't show up any error messages.

Additional info:
virt-who run at esx mode hasn't this problem

Comment 2 Radek Novacek 2014-08-01 14:23:17 UTC
Fixed in virt-who-0.10-5.el6

Comment 4 Liushihui 2014-08-08 07:28:31 UTC
Verified on virt-who-0.10-5.el6.noarch

Comment 5 Radek Novacek 2014-08-08 08:57:13 UTC
*** Bug 1125823 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2014-10-14 07:13:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1513.html


Note You need to log in before you can comment on or make changes to this bug.