Bug 1125814 - Fix error code to return of posix_fsync
Summary: Fix error code to return of posix_fsync
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 06:39 UTC by Zhang Huan
Modified: 2015-05-14 17:43 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Zhang Huan 2014-08-01 06:39:21 UTC
Description of problem:
In the case of fsync fails with error, the posix_fsync in posix xlator does not correctly return the error code. 

Version-Release number of selected component (if applicable):
The mainline, and 3.4, 3.5 and 3.6 branch are all affected.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Pranith Kumar K 2014-08-01 06:59:42 UTC
Zhang Huan,
    Seems like you know the issue, want to send a patch?

Pranith

Comment 2 Anand Avati 2014-08-01 07:06:42 UTC
REVIEW: http://review.gluster.org/8398 (storage/posix: fix return value of posix_fsync on error) posted (#1) for review on master by Zhang Huan (zhhuan@gmail.com)

Comment 3 Anand Avati 2014-08-01 07:40:11 UTC
REVIEW: http://review.gluster.org/8398 (storage/posix: fix issue in posix_fsync) posted (#2) for review on master by Zhang Huan (zhhuan@gmail.com)

Comment 4 Anand Avati 2014-08-01 23:38:25 UTC
COMMIT: http://review.gluster.org/8398 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b12ee8fbaf8f720f9072ea6b62bb844232870e6e
Author: Zhang Huan <zhhuan@gmail.com>
Date:   Fri Mar 7 11:08:47 2014 +0800

    storage/posix: fix issue in posix_fsync
    
    Fix the issue that posix_fsync does not correctly return and save
     error code in op_errno when call to sys_fdatasync fails.
    
    Change-Id: Id0b62cfa009dbb52c8a0992abd5c46330fa0a8c0
    BUG: 1125814
    Signed-off-by: Zhang Huan <zhhuan@gmail.com>
    Reviewed-on: http://review.gluster.org/8398
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Santosh Pradhan <spradhan@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2015-05-14 17:26:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:35:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:37:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:43:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.