Bug 1125818 - geo-rep: changelog_register fails when geo-rep started after session creation.
Summary: geo-rep: changelog_register fails when geo-rep started after session creation.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Kotresh HR
QA Contact: Bhaskar Bandari
URL:
Whiteboard:
Depends On:
Blocks: 1125843
TreeView+ depends on / blocked
 
Reported: 2014-08-01 06:52 UTC by Kotresh HR
Modified: 2015-05-13 16:53 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.6.0.27-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1125843 (view as bug list)
Environment:
Last Closed: 2014-09-22 19:45:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description Kotresh HR 2014-08-01 06:52:41 UTC
Description of problem:
changelog_register fails with ENOENT when geo-rep started just after session creation. It goes to Hybrid Crawl and never goes to changelog mode untill a stop and start of geo-rep.

Version-Release number of selected component (if applicable):


How reproducible:
Happens everytime.

Steps to Reproduce:
1. Create geo-rep session between master and slave
2. Start the geo-rep between master and slave
3. Check the log to see changelog_register failure or status to see "Hybrid Crawl"

Actual results:
changelog_register fails and always be in xsync mode

Expected results:
changelog_register should not fail, it should got to history, xsync and then changelog.

Additional info:

Comment 2 Kotresh HR 2014-08-04 07:44:26 UTC
Upstream Patch:
http://review.gluster.org/8399
Downstream Patch:
https://code.engineering.redhat.com/gerrit/#/c/30246/

Comment 3 Vijaykumar Koppad 2014-08-05 06:30:39 UTC
verified on the build glusterfs-3.6.0.27-1

Comment 6 errata-xmlrpc 2014-09-22 19:45:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.