Bug 1125826 - The page can't be access after restart if it was deployed using jboss management console
Summary: The page can't be access after restart if it was deployed using jboss managem...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1125827
TreeView+ depends on / blocked
 
Reported: 2014-08-01 07:38 UTC by Anping Li
Modified: 2015-05-15 00:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1125827 (view as bug list)
Environment:
Last Closed: 2014-08-01 16:26:52 UTC


Attachments (Terms of Use)

Description Anping Li 2014-08-01 07:38:27 UTC
Description of problem:
The page can be access after deployed package and enable it, However the page became inaccessible once the app was restart.
I found there only one blank directory under jbosseap/standalone/tmp/work/jboss.web/default-host. It seems jboss management deployed the package to memory, the package disappear after restart. 

Version-Release number of selected component (if applicable):
devenv-stage_939


How reproducible:
Always

Steps to Reproduce:
1.create one Jboss application.
2.port forward to your desktop and the go to http://127.0.0.1:9990/, deploy/enable one war package. for example: sample.war
3.access the http://url/sample
4. restart the application and access http://url/sample again
5. check the deployment directory
find . -name sample* 

Actual results:
For step 3: the page can be access.
For step 4: the page can't be access.
For step 5: there is only one empty directory jbosseap/standalone/tmp/work/jboss.web/default-host/sample

Expected results:
The war package should be kept in application, the page can be access after app restart.

Additional info:

Comment 1 Ben Parees 2014-08-01 16:26:52 UTC
Since you are using the jboss console directly to configure this application, you need to prevent openshift from rewriting the standalone.xml on restart.

To do so, set the following environment variable:
DISABLE_OPENSHIFT_MANAGED_SERVER_CONFIG=true

with that value set, you can manipulate the jboss configuration directly (including doing direct deployments like this) without losing the changes on restart.


Note You need to log in before you can comment on or make changes to this bug.