Bug 1125895 - Shell completion fails on ruby 1.8
Summary: Shell completion fails on ruby 1.8
Keywords:
Status: CLOSED DUPLICATE of bug 1123478
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 10:02 UTC by Tomas Strachota
Modified: 2016-04-22 14:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 13:57:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4162 None None None 2016-04-22 14:57:42 UTC

Description Tomas Strachota 2014-08-01 10:02:46 UTC
run `hammer -v shell` on ruby 1.8, hit <tab> to invoke command completion and see following exception:
<pre>
NoMethodError (undefined method `line_buffer' for Readline:Module)
</pre>

This method is really missing for for Readline version in 1.8.

Comment 1 Tomas Strachota 2014-08-01 10:02:47 UTC
Created from redmine issue http://projects.theforeman.org/issues/4162

Comment 2 Tomas Strachota 2014-08-01 10:02:51 UTC
Upstream bug assigned to tstrachota@redhat.com

Comment 4 Dominic Cleal 2014-08-01 13:57:56 UTC

*** This bug has been marked as a duplicate of bug 1123478 ***


Note You need to log in before you can comment on or make changes to this bug.