Bug 11259 - Unmounting smbfs shares fails when you are in the path of the share
Summary: Unmounting smbfs shares fails when you are in the path of the share
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-06 02:35 UTC by Michael Carew
Modified: 2007-04-18 16:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 03:11:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Carew 2000-05-06 02:35:13 UTC
Basically if you do the following:

mount -t smbfs -o guest,rw //windows/mp3 /mp3

then you are in /mp3 and you try and unmount the share it gives a device
busy error.

not so bad by itself

but when you reboot/halt the system from this path, the filesystem is not
properly unmounted, as it just sits there forever in the shutdown phase
trying to close the share. thus the local filesystem is not properly
unmounted.

Comment 1 Bernhard Rosenkraenzer 2000-08-09 15:21:05 UTC
The 1st part is not a bug, the second looks like it may be a problem in
reference counting in the kernel. I don't see any faulty code in mount.

Comment 2 Perry Harrington 2000-12-10 06:58:56 UTC
The only way that could happen is if the shell hasn't been killed by the time
the unmounting of remote filesystems is run.  This looks like an order of
operations issue in the shutdown scripts.


Note You need to log in before you can comment on or make changes to this bug.