Bug 1125917 - The new added jvm parameters were not added to the exisitng zend apps
Summary: The new added jvm parameters were not added to the exisitng zend apps
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 10:38 UTC by Meng Bo
Modified: 2015-05-15 00:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 12:31:51 UTC


Attachments (Terms of Use)

Description Meng Bo 2014-08-01 10:38:30 UTC
Description of problem:
According to trello card https://trello.com/c/YHgRD2fp/214-2-add-additional-jvm-heap-optimization-settings

There are 4 new jvm parameters were introduced in this sprint.

Check my old apps on STG, found the new params were not there.

[wordpress-bmeng1stg.stg.rhcloud.com 53da0bd2dbd93c3907000458]\> ps -ef |grep java
2759      93855      1  0 06:04 ?        00:00:00 /var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/bin/watchdog -c /var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/etc/watchdog-jb.ini -u 2759 -g 2759 -s java_daemon
2759      93857  93855  0 06:04 ?        00:00:00 /usr/bin/java -XX:+UseSerialGC -Xms20M -Xmx128M -Dzend.javamw.threads=20 -Dzend.javamw.ip=127.5.99.129 -Dzend.javamw.port=10001 -Dzend.javamw.log=0 -Dzend.javamw.logfile=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/var/log/javamw.log com.zend.javamw.JavaServer
2759      95099  74172  0 06:05 pts/1    00:00:00 grep java

After check in the gear, I found the file zend/versions/6.1/configuration/user-files/etc/watchdog-jb.ini was updated, but the zend/php-5.4/etc/watchdog-jb.ini was not. And 2nd one should be used by the java process.

Version-Release number of selected component (if applicable):
STG (devenv-stage_939)

How reproducible:
always

Steps to Reproduce:
1. Create apps on STG
2. STG got upgraded 
3. Check the java process on old apps

Actual results:
The new added jvm parameters were not found in the old zend apps

Expected results:
The new params should be appended.

Additional info:
Content of the files:
# cat zend/php-5.4/etc/watchdog-jb.ini
zend_wd.tmp_dir=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/tmp
zend_wd.process.java_daemon=/usr/bin/java -XX:+UseSerialGC -Xms20M -Xmx128M -Dzend.javamw.threads=20 -Dzend.javamw.ip=127.5.99.129 -Dzend.javamw.port=10001 -Dzend.javamw.log=0 -Dzend.javamw.logfile=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/var/log/javamw.log com.zend.javamw.JavaServer
zend_wd.env.java_daemon=CLASSPATH=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/bin/javamw.jar

# cat zend/versions/6.1/configuration/user-files/etc/watchdog-jb.ini
zend_wd.tmp_dir=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/tmp
zend_wd.process.java_daemon=/usr/bin/java -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -XX:GCTimeRatio=4 -XX:AdaptiveSizePolicyWeight=90 -Xms20M -Xmx128M -Dzend.javamw
.threads=20 -Dzend.javamw.ip=127.5.99.129 -Dzend.javamw.port=10001 -Dzend.javamw.log=0 -Dzend.javamw.logfile=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/var/
log/javamw.log com.zend.javamw.JavaServer
zend_wd.env.java_daemon=CLASSPATH=/var/lib/openshift/53da0bd2dbd93c3907000458/zend/php-5.4/bin/javamw.jar

Comment 1 Ben Parees 2014-08-01 12:31:51 UTC
We decided not to do a migration of those parameters because the file is user editable and we did not want to risk modifying something a user had customized.


Note You need to log in before you can comment on or make changes to this bug.