Bug 1125944 - (6.4.z) Issues with CalendarBasedTimeoutTestCase
Summary: (6.4.z) Issues with CalendarBasedTimeoutTestCase
Keywords:
Status: CLOSED DUPLICATE of bug 1213875
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: EAP 6.4.1
Assignee: Panagiotis Sotiropoulos
QA Contact: Petr Kremensky
URL:
Whiteboard:
: 1141120 (view as bug list)
Depends On:
Blocks: 996500
TreeView+ depends on / blocked
 
Reported: 2014-08-01 11:59 UTC by Hynek Mlnarik
Modified: 2015-09-01 03:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-27 08:47:39 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBQA-10939 Major Closed Intermittent fail of org.jboss.as.ejb3.timer.schedule.CalendarBasedTimeoutTestCase.testCalendarBasedTimeout 2017-11-09 17:22:03 UTC
Red Hat Bugzilla 980923 None None None Never
JBoss Issue Tracker WFLY-2881 Blocker Closed org.jboss.as.ejb3.timer.schedule.CalendarBasedTimeoutTestCase#testCalendarBasedTimeout 2017-11-09 17:22:03 UTC
JBoss Issue Tracker WFLY-3947 Major Resolved Incorrect EJB Calendar Based Timeouts 2017-11-09 17:22:03 UTC

Internal Links: 980923

Comment 1 Carlo de Wolf 2014-09-15 12:23:06 UTC
java.lang.AssertionError: Eastern European Time Calendar.HOUR_OF_DAY java.util.GregorianCalendar[time=1406844000000,areFieldsSet=true,areAllFieldsSet=true,lenient=true,zone=sun.util.calendar.ZoneInfo[id="ART",offset=7200000,dstSavings=3600000,useDaylight=true,transitions=184,lastRule=java.util.SimpleTimeZone[id=ART,offset=7200000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=3,startDay=-1,startDayOfWeek=6,startTime=0,startTimeMode=1,endMode=2,endMonth=8,endDay=-1,endDayOfWeek=5,endTime=86400000,endTimeMode=0]],firstDayOfWeek=1,minimalDaysInFirstWeek=1,ERA=1,YEAR=2014,MONTH=7,WEEK_OF_YEAR=31,WEEK_OF_MONTH=1,DAY_OF_MONTH=1,DAY_OF_YEAR=213,DAY_OF_WEEK=6,DAY_OF_WEEK_IN_MONTH=1,AM_PM=0,HOUR=1,HOUR_OF_DAY=1,MINUTE=0,SECOND=0,MILLISECOND=0,ZONE_OFFSET=7200000,DST_OFFSET=3600000] expected:<0> but was:<1>

Comment 2 Carlo de Wolf 2014-09-15 12:32:58 UTC
Looks like a bug in the JDK:
sun.util.calendar.ZoneInfo[id="ART",offset=7200000,dstSavings=3600000,useDaylight=true,transitions=184,lastRule=java.util.SimpleTimeZone[id=ART,offset=7200000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=3,startDay=-1,startDayOfWeek=6,startTime=0,startTimeMode=1,endMode=2,endMonth=8,endDay=-1,endDayOfWeek=5,endTime=86400000,endTimeMode=0]] Eastern European Time

$ java -version
java version "1.7.0_65"
OpenJDK Runtime Environment (fedora-2.5.1.3.fc20-x86_64 u65-b17)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

Comment 3 Petr Kremensky 2014-09-15 12:39:29 UTC
*** Bug 1141120 has been marked as a duplicate of this bug. ***

Comment 4 Hynek Mlnarik 2015-03-24 08:45:35 UTC
Seen in 6.4.0.CR1

Comment 5 Panagiotis Sotiropoulos 2015-03-24 13:09:30 UTC
See also : https://issues.jboss.org/browse/WFLY-2881 and https://issues.jboss.org/browse/WFLY-3766

Comment 6 Richard Janík 2015-04-10 07:03:29 UTC
Seen in 6.4.0.CR2

Comment 7 Panagiotis Sotiropoulos 2015-04-10 07:57:48 UTC
The bug is actual in 6.4.x. 
It could be related with the change of CET to CEST.

Comment 8 Panagiotis Sotiropoulos 2015-04-10 11:31:06 UTC
There should be some issue with the set method of Calendar class in open jdk.

Comment 9 Panagiotis Sotiropoulos 2015-04-10 11:32:53 UTC
From documentation : add(f, delta) adds delta to field f. This is equivalent to calling set(f, get(f) + delta).

So, https://github.com/wildfly/wildfly/pull/6614/files can be considered a workaround.

Comment 11 Panagiotis Sotiropoulos 2015-04-23 08:15:56 UTC
With oracle jdk 7u65 works fine, but with oracle 7u80 the issue is there.

Comment 12 Panagiotis Sotiropoulos 2015-04-27 08:47:39 UTC
Resolved in BZ1213875 : https://bugzilla.redhat.com/show_bug.cgi?id=1213875

*** This bug has been marked as a duplicate of bug 1213875 ***

Comment 13 JBoss JIRA Server 2015-04-27 08:51:25 UTC
Panagiotis Sotiropoulos <psotirop@redhat.com> updated the status of jira WFLY-2881 to Closed

Comment 14 JBoss JIRA Server 2015-04-27 09:18:31 UTC
Panagiotis Sotiropoulos <psotirop@redhat.com> updated the status of jira JBQA-10939 to Closed


Note You need to log in before you can comment on or make changes to this bug.